
J
O

H
N

 S
T

E
V

E
N

S
O

N

TIPS & TRICKS
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Tips and Tricks

• Workspaces

• Windows and Views

• Projects

– Sharing Projects

– Source Control

– Editor Tips

• Debugging

– Debug Options

– Debugging Without a Project

– Graphs

• Using Eclipse Plug-ins
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Use Multiple Workspaces

• Multiple Users: Keep separate workspaces for each user on a shared 

machine

– Custom preferences, layouts, etc will be maintained on a per user basis

– Each user can be working on specific project(s) that would only be applicable to a 

their workspace

• Project Organization: Break up all your CCS projects into separate 

workspaces for better maintenance

– A workspace for each software release

– A workspace for each module/feature of a release

– etc

• Performance: The larger the contents of the workspace (number of open 

projects), the greater the impact on performance of CCS
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Clean Your Workspace

• Workspace folder can get corrupted over time

• Good idea to periodically clean your workspace for best CCS performance 

and stability

• To clean workspace, either:

– Delete „.metadata‟ folder in workspace folder

– Use a new workspace folder

• Before cleaning, save current workspace settings so they can be imported 

into the new workspace

– Save settings: 'File->Export...->General->Preferences->To preference file' 

– Import Settings: 'File->Import...->General->Preferences->From preference file'
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Window Types

Detached: 

Like having float in main window off in 

CCSv3

Fast view: Hidden until you click on the 

button to restore them.  Click on another 

window to hide.

Tab Group: 

Several 

windows

grouped 

together

Editor: 

Only editor 

windows are 

part of this 

group
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Windowing tips

• Double-clicking on the title bar of a window will maximize the window

– Double-clicking again will restore it to its previous size

• Fast-view windows are great for windows you use infrequently but need a lot of 

space when you do use them

• The window that has focus is indicated by a blue border and heading

Current window
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Customizing Perspectives

• You can customize the menu items and toolbars in your perspective

– Right click on the toolbar

– select customize perspective

• Change keyboard shortcuts

– Window->Preferences

– search for “keys”
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Using the keyboard…

For the keyboard fans, some useful default keystrokes:

– Ctrl+Shift+P: Build the Active Project (in All Perspectives)

– Ctrl+Alt+P: Rebuild the Active Project (in All Perspectives)

– Ctrl+F: Find and Replace (in Editor window)

– Ctrl+H: Find files in the filesystem 

– F8: Run Free (in Debug Perspective)

– F5 and F6: C-step into and step over

– Alt+C: Connect to target (in Debug Perspective)

– Ctrl+G: Go to Address (in Disassembly and Memory views)

• All key bindings can be viewed and modified from: („Window-

>Preferences->General->Keys‟)



J
O

H
N

 S
T

E
V

E
N

S
O

N

Accessing Views

• To open a new view go to the Windows -> Show View Menu

– Common views for the

current perspective

– Recently opened views

• To access views that are 

not listed select Other…

• The „View‟ main menu has

a subset of the most popular views
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Sharing Projects

• Sharing “Simple” projects (all source/header files are contained 

in the project folder)

• Sharing “Linked file” projects and all source (project uses linked 

files)

• Sharing “Linked file” projects only (no source)

– Only the project folder is shared (person receiving project already has all 

source)

– Effort involves making the project “portable”

• Eliminate absolute paths in the project
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Sharing Projects –Simple Projects

• Easy to share projects that conform to standard Eclipse behaviour 

(no linked files):

– The entire project folder can be distributed to another “as-is” 

– The user who receives the project can import it into their workspace using 

„Project -> Import Existing CCE/CCS Project‟ and selecting the copied folder

– Works well for simple projects that only reference files inside the project 

folder
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Sharing Projects –Linked File Projects (1)

• Use the CCS Export Project to create an archive (zip) file that contains the project folder and all project 

linked source files

– Note that this technique will fail if Linked Path variables are used!

• Exporting your project: These instructions cover how to archive your project on the source computer

– File -> Export

– Expand "General" and select "Archive File". Click "Next"

– The dialog that appears allows you to select which projects you wish to export to the archive. When you select a 

project it will show you on the right hand side all of the items it is going to export. Check the box beside the project to 

indicate that you want to archive it.

– Specify a name for your archive and select either zip or tar, then click "Finish"

– You now have a zip file on your computer containing the project. Not only did it copy in the files that are physically 

located in your project directory but it also copied in your linked/referenced resources
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Sharing Projects –Linked File Projects (2)

• Importing the project on another machine: These instructions cover how to import the project from 

the archive. What happens is that it will import the project into your workspace

– Project -> Import Existing CCS/CCE Eclipse Project

– Change the radio button selection at the top to "Select archive file"

– Browse to and select your archive file

– It will list all of the projects found in the archive. The are all selected by default. Select the ones you want and click 

"Finish"

– The project is now in your workspace

• For linked/referenced resources it will copy those files from the archive in place then at the same path 

where they were located on the original computer:



J
O

H
N

 S
T

E
V

E
N

S
O

N

Portable Projects –Linked Files

• When you link files it creates an absolute path in the project file

– Not a problem if you plan on exporting your project + source (see previous slide)

– Otherwise it can cause problems sharing just the project file(s) only

• Avoid this by using Linked Path variables to contain the paths and have the project reference the linked file using the path
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Portable Projects –Linked Files

• Link your file to the project using the variable via „New->File‟:

#1: Click „Advanced‟

#2: Check this option #3: Click „Variables‟

#4: Select the variable 

and hit „Extend‟

#5: Select the desired file 

in that variable path and hit „OK‟
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Portable Projects –Linked Files

• The project will reference the linked 

file using the Linked Path variable, 

instead of an absolute path

• Looking at the file properties for the 

linked source file will show that is 

using the Linked Path variable
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Portable Projects –Automated Definition of 
Linked Path Variables

• Use „macro.ini‟ files to enable auto-definition of Linked Path variables on project 

import into another workspace

– When a project is being imported (via Import Wizard) and a macros.ini is found in the root project 

location, it will auto-add any variables defined in the file to the Linked Resources list

– TIP: Relative paths are supported in the „macro.ini‟ file
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Portable Projects –Environment Variables 
Macros

• Avoid absolute paths in the build options by using Environment 

Variables and Macros

• Every project automatically defines a number of different macros that 

can be used in build options
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Portable Projects –Using Macros

• There are Configuration 

and Project level macros

– User may also define their 

own macros similarly to how 

linked resource path variables 

are defined
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Version Control –Check in Which Files?

• Several files/folders are generated by CCS inside the 

project folder

– .cdtbuild, .cdtproject, .project are all Eclipse CDT project files

and should be checked in

– .ccsproject is a CCS specific project file that should be checked 

in

– .settings folder is a standard Eclipse folder that contains 

settings that apply to the project. This folder should be checked 

in 

– .launches directory is generated when you start a debug 

session. It is not related to the build of your project and is not

necessary to check in

– The contents of the project configuration folder 

(Debug/Release) does not need to be checked in

http://publib.boulder.ibm.com/infocenter/rtnlhelp/v6r0m0/index.jsp?topic=/org.eclipse.cdt.doc.user/getting_started/cdt_w_existing_code.htm
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Source Code Editor

• CCSv4 comes with an excellent, feature rich editor

Collapse and 

expand text

Editor tabs

Outline view displays 

lists structural 

elements for the 

selected source file

Code Completion
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Advanced Editor Features

• Code Completion

– Complete word

– Auto-member information

– Auto-parameter information

– …

• Navigation

– Back/Forward buttons

– Back to last edit button

– Go to definition

– Go to declaration

• Show line numbers

• Code Folding

– Collapse functions
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Performance Tip: Indexer

• Don‟t use the CCS editor or don‟t care about advanced editor features?

– Turn off the Indexer 

• The indexer constantly scans all open projects to support some advanced editor features

• The indexer can use a decent amount of system resources, causing CCS to appear 

sluggish

– This is most evident with large projects or many open projects in the workspace (or 

both)

• The default CCS setting is to have the full indexer enabled

– Where to adjust indexer settings?

• In the project properties (right-click on project and select „Properties‟)
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Source Templates

• CCS provides source templates 

– Ex: Hello World

• Type in „h‟ in the editor and use „Content Assist‟ by pressing „CTRL+SPACE‟ keys (can 

also right-click in the editor and select „Content Assist‟ from the context menu)

– Select „helloworld‟ 

• Create custom templates

– Window->Preferences…->C++->Editor->Templates
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Local History

• CCS keeps a local history of source 

changes

• You can compare your current 

source file against any previous 

version or replace it with any 

previous version

– Double-click on a revision to open it in 

the editor

– Right-click on a revision to compare 

that revision to the current version

• CCS also keeps project history 

– Recover files deleted from the project

– Right-click on the project and select 

“Recover from Local History” in the 

context menu

„History‟ view

File Comparer
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Edit Markers

• If you have the line number column on it also indicates changes 

in your source file since your last save

Modified lines

Deleted lines

Inserted lines
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CCS Project Debug Properties

• Debugger settings when starting a debug 
session for the project (“Debug Active 
Project”)

• This will change options for an existing 
Project Debug Session launch

• Non project debug session launches can be 
modified from „Target->Debug…‟ under the 
„Non-Project Debug Session‟ list
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CCS Debug –Main Options

• Use the „Main‟ tab to specify the executable to load when 
starting a debug session 

– Default name is the name of the executable generated by CCS

– This tab only exists for project debug session launches
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CCS Debug –Debugger Options

• Use the „Debugger‟ tab to: 

– Specify which CPU to load the executable on (for multi-core devices)

– Specify to load the program (default) or just symbols only (to debug 
code in flash, etc)
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CCS Debug –Target Options

• The „Target‟ tab can be used to set a variety of debug options 
like auto-run to main, auto-connect to a HW target, real-time 
options, program verification on load, etc…
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CCS Debug –Source Options

• The „Source‟ tab allows you to add additional source lookup 
search paths

– All paths to any source files in your project are automatically added by 
default
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CCS Debug –Common Options

• The „Common‟ tab contains a bunch of miscellaneous options

– Can specify the debugger to send all CIO to a file instead of the console
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Launching the Debugger –Debug Launch

• Debug „Launch‟: Cached 

information from the last 

launch

• Start debug session by 

selecting a launch from list of 

recent launches

• Launch options can be 

modified with the „Debug‟ 

option
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Debugger Options

• Many debugging features (real-time mode, auto-run to main, etc) can be 

enabled from the Debugger Options

• There are three places to configure the Debugger Options

– Global (workspace level): Windows->Preferences->CCS->Debug->Debugger 

Options->Generic

– Project: Debug/Launch Properties: (project)->Debug Properties

– Current Debug Session: Tools->Debugger Options->Generic Debugger Options

• Use the “Remember My Settings” option to have the settings apply for subsequent debug 

sessions
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Debugging Without a Project

• CCS does not know the location of source files for a project-less debug 

of an executable

– Loading executable *.out file in CCS without the project open

• CCS can be instructed where to find the source files one of two ways:

– Tell CCS where the first file is and let CCS find the rest of the files using relative 

path information in the symbols

– Set “Source Lookup Paths” for CCS to scan when looking for source files:

• Set for current debug session

• Set for launch configuration - apply for every debug session started for that target only

• Set at global (workspace) level – apply for any debug session started with this workspace
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Source Lookup Paths: Method #1 
(recommended)

• If a source file cannot be found during debug, it 

will be indicated in the editor

• Use „Locate the Source File…‟ button to browse to 

the location of the source file

– The debugger can then find other source files in 

the same location or use relative path information 

to find files relative to the current file

– Location is remembered for future loads of the 

same program

• This method has the best performance for finding 

source files
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Source Lookup Paths: Method #2 –Per Debug Context

• Source lookup paths can also be explicitly 

specified for each debug context

• Right-click in the „Debug‟ view and select „Edit 

Source Lookup…‟ in the context menu

• To add a file system path, select „File System 

Directory‟ to browse to and add paths

• For multi-core debugging, each debug context has 

its own set of source lookup paths

• WARNING: CCS will do recursive searches inside 

the specified directories when searching for files! If 

the directories have many subfolders and many 

files inside, the search may be slow and method 

#1 in the previous slide is recommended
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Source Lookup Paths Method #2 –Launch 
Configuration

• Debug Properties->CCS Debug->Source

• The „Source‟ tab allows you to add additional source lookup search 
paths

– All paths to any source files in your project are automatically added by default



J
O

H
N

 S
T

E
V

E
N

S
O

N

Source Lookup Paths Method #2 –Global Setting

• Source lookup paths can also be set globally to apply for all debug contexts (in 

a multi-core environment) and debug sessions
– „Windows->Preferences…->C/C++->Debug->Common Source Lookup Path
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More Debugging: Source Lookup Paths

• Once the path is known to the 

debugger (using either method), 

the source file will be opened in 

the debugger
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Graphs

• Export Graph Properties to a text file for easy import next 

time or to share to someone else
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Scripting Console

• Command line operation of CCS

• View->Scripting Console

• Press TAB for a list of commands

– Press TAB for partially typed commands for auto-complete feature 

• To get documentation for a command

– js:> help <command>

• JavaScript shell and has access to all DSS APIs

• Run DSS scripts from the console

• Create your own custom commands

– Create a JavaScript function in a *.js file

– Load the custom Javascript file

Å loadJSFile <full path>/myCustomConsoleCmd.js 

• Optional boolean second parameter that will auto-load the script 

– The function can now be called by name from inside the Scripting Console



J
O

H
N

 S
T

E
V

E
N

S
O

N

Scripting Console

• View->Scripting Console

• Press TAB for a list of commands

– Press TAB for partially typed commands 

for auto-complete feature 

• To get documentation for a command

ï js:> help <command>
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Scripting Console

• Both the Scripting Console and GEL can be used for automation

• GEL can be used only within an active debug session and (mostly) apply 

to a debug context

• The Scripting Console can be used anytime (though certain commands 

will not work without a debug session)

• Scripting Console and GEL can both add menus to the custom „Scripts‟

– GEL: hotmenu <function>

– Scripting Console: hotmenu.addJSFunction
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Scripting Console

// Add entries to the 'Scripts' menu

hotmenu.addJSFunction("Launch TCI6488 Simulator, Little Endian", "tci6488_le_sim()");

hotmenu.addJSFunction("Launch TCI6488 Simulator, Big Endian", "tci6488_be_sim()");

// Path to folder with target setup ccxml files

var setupConfigFileFolder = "C:/Documents and Settings/login/user/CCSTargetConfigurations";

// configure for a TCI6488 Symmetric Simulator, Little Endian

function tci6488_le_sim()

{

ds.setConfig(setupConfigFileFolder + "/tci6488_le_sim.ccxml");

debugSessionCPU1 = ds.openSession("*", "C64+_0");

debugSessionCPU2 = ds.openSession("*", "C64+_1");

debugSessionCPU3 = ds.openSession("*", "C64+_2");

}

é
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Eclipse Plug-ins - Basics

• CCSv4 is based on Eclipse and is able to leverage many Eclipse of the 

huge selection of 3rd party plug-ins available

– http://www.eclipseplugincentral.com

• CCSv4 is based off Eclipse 3.2 and CDT 3.1

– Look for plug-ins that support those versions for best chance of compatibility

• CCSv4 is using modified version of Eclipse and CDT

– Plug-ins related to debugging will have the most compatibility issues and are not 

recommended with CCSv4 (breakpoints, etc)

– Plug-ins strictly related to the IDE have good compatibility (code analysis, source 

code control, modelling, editors, Perl development…)

http://www.eclipseplugincentral.com/
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Eclipse Plug-ins - Installation

• Use the Eclipse Update 

Manager 

– Help->Software Updates-

>Find and Install->Search 

for new updates to install 

(specify remote site (URL) 

or local site (directory)

• Many plug-ins are simply 

downloaded and copied 

into the .\ccsv4\eclipse 

folder
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Useful Eclipse Plug-ins

• Offline Mediawiki (TI)

– An offline version of the Mediawiki server accessible from the CCSv4 Help

– http://processors.wiki.ti.com/index.php/CCSv4_Mediawiki_Plug-in_Download

• Cgxml for CCSv4 (TI)

– Incorporates the command-line Cgxml scripts for post processing of output files

– http://processors.wiki.ti.com/index.php/Code_Generation_Tools_XML_Processing_Scripts_Plug-in_for_CCS

• Anyedit (3rd party)

– Adds some useful capabilities to the built-in editor like Save All opened files, convert tabs to spaces, make block 

indentations, etc.

– http://andrei.gmxhome.de/anyedit/

• Pathtools (3rd party)

– Extends the file browsing capabilities of the Eclipse C/C++ project view 

– Also allows adding your own file editor

– http://eclipse.dzone.com/articles/pathtools-simple-yet-useful-ec

• A list of plug-ins that have been validated with CCSv4 is available
– http://processors.wiki.ti.com/index.php/Category:CCS_Plugins

http://processors.wiki.ti.com/index.php/CCSv4_Mediawiki_Plug-in_Download
http://processors.wiki.ti.com/index.php/CCSv4_Mediawiki_Plug-in_Download
http://processors.wiki.ti.com/index.php/CCSv4_Mediawiki_Plug-in_Download
http://processors.wiki.ti.com/index.php/Code_Generation_Tools_XML_Processing_Scripts_Plug-in_for_CCS
http://processors.wiki.ti.com/index.php/Code_Generation_Tools_XML_Processing_Scripts_Plug-in_for_CCS
http://processors.wiki.ti.com/index.php/Code_Generation_Tools_XML_Processing_Scripts_Plug-in_for_CCS
http://andrei.gmxhome.de/anyedit/
http://andrei.gmxhome.de/anyedit/
http://eclipse.dzone.com/articles/pathtools-simple-yet-useful-ec
http://eclipse.dzone.com/articles/pathtools-simple-yet-useful-ec
http://eclipse.dzone.com/articles/pathtools-simple-yet-useful-ec
http://eclipse.dzone.com/articles/pathtools-simple-yet-useful-ec
http://eclipse.dzone.com/articles/pathtools-simple-yet-useful-ec
http://eclipse.dzone.com/articles/pathtools-simple-yet-useful-ec
http://eclipse.dzone.com/articles/pathtools-simple-yet-useful-ec
http://eclipse.dzone.com/articles/pathtools-simple-yet-useful-ec
http://eclipse.dzone.com/articles/pathtools-simple-yet-useful-ec
http://processors.wiki.ti.com/index.php/Category:CCS_Plugins

