CCSv4 Usage for DA8xx SDK

From Texas Instruments Wiki
Jump to: navigation, search

Return to Overview of DA8xx SDK Getting Started Guide

Introduction

This page describes the very basic functions of CCSv4 which are required to build and run PA Framework. More information, documentation and tutorials on using CCSv4 are available at: Category:Code Composer Studio v4

Launch CCSv4 and Choose Workspace

  • Start CCSv4 by selecting following link: Start Menu -> Programs -> Texas Instruments -> Code Composer Studio v4 -> Code Composer Studio v4
  • CCS will ask to select a workspace.
  • Creating separate workspaces for different H/W is convenient. For example:
    • "workspace_EVM" for DA8xx EVM
    • "workspace_Cust" for Customer H/W
Ccs4 workspace.jpg 


Open Existing Project and Build

  • Select "Project -> Import Existing CCS/CCE Eclipse Project" from CCS menu
  • Browse root directory where desired “.project” file exists
Ccs4 openProject.png
  • Make sure that only the desired project is checked and then click the Finish button.
  • To build the Project, select "Project -> Build Active Project" from menu.
    • If there are multiple projects, right click on the project to build and choose “Set as Active Project”.


Target Configuration

  • Select "Target -> New Target Configuration…" from CCS menu.
  • Specify a file name or use default.
  • Select "Spectrum Digital XDS510USB Emulator" as Connection
  • Check "DA830/DA828" as Device and save. 
Ccs4 targetConfig1.jpg 

  • Open Target Configuration view in CCS by selecting "Window -> Show view -> Target Configurations" from menu.
  • Select newly created configuration, right-click on it and set it as default.

Ccs4 targetConfig2.jpg


Connect Target and Load/Run Program

  • Connecting Target
    • Select "Target -> Launch TI Debugger" from menu to start a debug session.
    • CCS will switch to Debug perspective with three devices (DSP, ARM and ETB).
    • Select device to connect and then go to "Target -> Connect Target" from menu.

Note: To connect ARM, you need to connect the DSP first (even if you do not load anything to DSP), then connect ARM (Reason: DSP’s GEL file enables ARM)

Ccs4 targetConnect.jpg
  • Loading Program
    • Choose desired device (DSP or ARM)
    • Go to "Target -> Load Program" from menu.
    • Click “Browse” to choose a prebuilt *.out or click “Browse project..” to choose *.out of the open projects.
    • Choose desired *.out and click OK.
Ccs4 loadProgram.jpg
  • Running Program
    • Go to "Target -> Run" or Press F8