Please note as of Wednesday, August 15th, 2018 this wiki has been set to read only. If you are a TI Employee and require Edit ability please contact x0211426 from the company directory.

CCSv5 Usage for DA8xx SDK

From Texas Instruments Wiki
Jump to: navigation, search

Return to Overview of DA8xx SDK Getting Started Guide

Introduction

This page describes the very basic functions of CCSv5 which are required to build and run PA Framework. More information, documentation and tutorials on using CCSv5 are available at http://processors.wiki.ti.com/index.php/Category:Code_Composer_Studio_v5

Launch CCSv5 and Choose Workspace

  • Start CCSv5 by selecting following link: Start Menu -> Programs -> Texas Instruments -> Code Composer Studio 5.3.0 -> Code Composer Studio 5.3.0
  • CCS will ask to select a workspace.
  • Creating separate workspaces for different H/W is convenient. For example:
    • "workspace_EVM" for DA8xx EVM
    • "workspace_Cust" for Customer H/W
Ccs4 workspace.jpg 

CCSv5 Tool Discovery

  • In CCSv5, go to Windows->Preferences->Code Composer Studio ->RTSC->Products and Windows->Preferences->Code Composer Studio ->Build->Compilers.
  • Add the directory where your tools are installed to the Tool discovery path. This include directories where the compiler tools,IPC, XDAIS, XDC, DSP/BIOS are installed.
Tooldiscovery.JPG
Comp td.JPG


Open Existing Project and Build

  • Select "Project -> Import Existing CCS/CCE Eclipse Project" from CCS menu
  • Browse root directory where desired “.project” file exists
Ccsv5 p.JPG
  • Make sure that only the desired project is checked and then click the Finish button.
  • To build the Project, select "Project -> Build Project" from menu.
    • If there are multiple projects, right click on the project to build and choose “Set as Active Project”.


Target Configuration

  • Right click on Active project and select New->Target Configuration File.
  • Specify a file name or use default.
  • Select "Spectrum Digital XDS510USB Emulator" as Connection
  • Check "DA830/DA828" as Device and save. 
765x438px 

Helpful tips image.jpg

Useful Tip

  • If you don't see "DA830/DA820" device available, there are two files that need to be copied over to the ccsv5 directory.
    • They are available in the following zip folder: File:DA830 xml files.zip.
      • Place dskda830.xml under - ccsv5/ccs_base/common/targetdb/boards
      • Place DA830-DA828.xml under - ccsv5/ccs_base/common/targetdb/devices
      • Restart CCS v5.3. The device should now be available.
  • Note that the DA830 should have been installed as part of the "Davinci" device selection during target type installation. See Installing_Tools_Required_for_DA8xx_SDK#Installing_CCSv5


  • Open Target Configuration view in CCS by selecting "Window -> Show view -> Target Configurations" from menu.
  • Select newly created configuration, right-click on it and set it as default.

Ccs4 targetConfig2.jpg


Connect Target and Load/Run Program

  • Connecting Target
    • Select "View -> Debug" from menu to start a debug session.
    • CCS will switch to Debug perspective with devices DSP and ARM .
    • Select device to connect and then go to "Run -> Connect Target" from menu.

Note: To connect ARM, you need to connect the DSP first (even if you do not load anything to DSP), then connect ARM (Reason: DSP’s GEL file enables ARM)


Ccs5 Target Connect image.jpg

Loading Program

  • Choose desired device (DSP or ARM)
  • Go to "Run -> Load -> Load Program" from menu.
  • Click “Browse” to choose a prebuilt *.out or click “Browse project..” to choose *.out of the open projects.
  • Choose desired *.out and click OK.
Ccs4 loadProgram.jpg
  • Running Program
    • Go to "Run -> Resume" or Press F8