ClearCase plugin installation

From Texas Instruments Wiki
Jump to: navigation, search

Introduction

If you are using ClearCase as your source control repository you may want to install the Eclipse ClearCase plug-in into CCS to enable you to perform ClearCase operations from within the CCS environment.

In this article we are documenting two installation procedures depending on the ClearCase functionality you want to install in CCS. Please take the time to read carefully the following few paragraphs before selecting your installation method.

Once you are clear which installation procedure is applicable for you then go for the detailed procedure in this article.

In CCS/Eclipse the ClearCase functionality can be used in two slightly different ways that require different Eclipse plugins to be installed:

  • ClearCase plugin: This is the way to go if you actually have the ClearCase software installed on your workstation/laptop. More information on the ClearCase plug-in is available at this link on IBMs website.
  • ClearCase Remote Client plugin: This is the way to go if you actually do not have the ClearCase software installed on your workstation/laptop and your ClearCase administrators, or the "people in the know" tell you that you have to use the ClearCase Remote Client functionality. In this case do not install the regular ClearCase plugin but the CCRC plugin as described below.

ClearCase Plugin Installation Procedure

This is the installation procedure for the ClearCase Plugin, check the other installation procedure if what you need the Remote Client Plugin.

Dependencies

You must have the ClearCase client software installed on your computer.

CCSv4.x.  CCSv4.0 and later are based on the Eclipse open source software framework. The instructions below are for installing the plug-in for Eclipse 3.2 which is what CCSv4.0 is based on. If you are using a newer version of Eclipse the link in the overview section provides links to the plug-ins for newer versions of Eclipse.

Procedure

Obtain the ClearCase Plugin

The plug-ins are called "Adapters" on the IBM website. For CCSv4 download the Adapter for Eclipse 3.2. Download the correct plug-in from here: IBM Rational web site or here

There you will find the plugins for Windows, Linux and Solaris platforms.

Installation Instructions

  1. Download the zip file appropriate for your operating system. Extract the contents of the file to a directory in your file system.
  2. In Eclipse, select Help > Software Updates > Manage Configuration. In the Product Configuration window, click the "Add an Extension Location" link in the Eclipse platform pane.
  3. The Browse for Folder dialog prompts you to choose an extension location, expand the My Computer entry and navigate to the directory that contains the contents of the extracted zip file. Expand the Eclipse folder and click OK.
  4. The Install/Update dialog prompts you to restart the workbench. Click "Yes".
  5. In the Eclipse window, click Window > Customize Perspective.
  6. In the Customize Perspective dialog box, click the Commands tab, ensure that the ClearCase' option under the Available command groups column is checked, and click "OK".

Note: This installation procedure will NOT disable previous versions of the ClearCase SCM Adapter feature. You MUST disable the earlier versioned features manually in the Manage Configuration sheet in order to ensure proper functionality. Following this procedure, the ClearCase menu option appears in the main menu of your Eclipse window, the ClearCase icons appear, and the installation of the ClearCase SCM Adapter is complete.

ClearCase Remote Client Plugin Installation Procedure

This is the installation procedure for the ClearCase Remote Client (CCRC) Plugin, check the other installation procedure if what you need the "regular" ClearCase Plugin (that uses the ClearCase software already installed on your workstation/laptop).

Dependencies

CCSv4.x.  CCSv4.0 and later are based on the Eclipse open source software framework. The instructions below are for installing the plug-in for Eclipse 3.2 which is what CCSv4.0 is based on.  If you are using a newer version of Eclipse then the location Callisto "Remote Site" used in the installation of the GEF plugin in the following instructions needs to be updated to match the Eclipse revision that CCS is based on.

Procedure

Install GEF plugin

The first step of the procedure is to install the GEF plugin from Eclipse.org. This required as the ClearCase Remote Client (CCRC) plugin depends on it.

To install this plugin go to Help->Software Updates->Find and Install... menu entry.

Select the Search for new features to install option.

SearchForUpdates.PNG

For Eclipse to find the GEF plugin you first need to make sure you add a “New Remote Site” with the following charateristics:

Select this site once it has been added and follow the wizard, after it connects it should list a bunch of updates. Select your preferred mirror site.

NewRemoteSite.PNG

Pick the GEF (Graphical Editing Framework) plugin from the list of available plugins and continue with the wizard to proceed with the installation.

Gef.png

Once the installation is completed CCS/Eclipse should ask you to restart.

Install CCRC plugin

The second step in this procedure is to install the CCRC plugin.

To install this plugin go to Help->Software Updates->Find and Install... menu entry.

Select the Search for new features to install option.

SearchForUpdates.PNG

For Eclipse to find the ClearCase Remote Client plugin you first need to make sure you add a “New Remote Site” with the following charateristics:

Select this site once it has been added and follow the wizard.

Pick the ClearCase Remote Client for Eclipse plugin from the list of available plugins and continue with the wizard to proceed with the installation.

Ccrc-install.png

Once the installation is completed CCS/Eclipse should ask you to restart.

After CCS has restarted, the first thing you'll want to do is to open the ClearCase perspective (Window->Open Perspective->Other...->ClearCase).