Please note as of Wednesday, August 15th, 2018 this wiki has been set to read only. If you are a TI Employee and require Edit ability please contact x0211426 from the company directory.

Compatibility between DSP/BIOS versions and Code Generation Tools

From Texas Instruments Wiki
Jump to: navigation, search

DSP/BIOS version 5.33 or greater has been modified to be compatible with the latest Code Generation Tools, this includes:

  • Any version of 5.0.x and 5.1.x for the C2000 Code Generation Tools
  • Any version of 4.1.x and 4.2.x for the C5500 Code Generation Tools
  • Any version of 6.0.x and 6.1.x for the C6000 Code Generation Tools
  • Version 6.1.x will issue a linker warning regarding the use of trampolines for certain DSP/BIOS calls (only affects C62x, C67x, C672x). This is a known issue and will be addressed in future DSP/BIOS releases. This does not affect functionality.


DSP/BIOS 5.33 can be obtained from the Update Advisor DSP/BIOS Product Releases page:

https://www-a.ti.com/downloads/sds_support/targetcontent/bios/index.html

Previous versions of DSP/BIOS (5.30, 5.31, 5.32) are only compatible with:

  • Version 5.0.x or earlier for the C2000 Code Generation Tools
  • Version 4.1.x or earlier for the C5500 Code Generation Tools
  • Any version of 6.0.x and 6.1.x for the C6000 Code Generation Tools
  • Any version of 4.1.x and 4.2.x for the C5400 Code Generation Tools (Note: Last version of DSP/BIOS supported for C5400 devices is v5.31.09).