Please note as of Wednesday, August 15th, 2018 this wiki has been set to read only. If you are a TI Employee and require Edit ability please contact x0211426 from the company directory.

Creating CCS Project for Codec Engine app

From Texas Instruments Wiki
Jump to: navigation, search

Introduction

Code Composer Studio (CCS) contains application build support in the form of a "CCS Project". Many TI SW components contain CCS project files (.pjt) that can be opened by a CCS user and used as a starting point for their own application development.

Codec Engine contains many examples for creating applications using CE, but these examples do not come in the form of a CCS project. This article describes the steps needed to create a CCS project for building a CE application.

Description

CCS contains a "Project Creation Wizard" that is used to create the initial project contents. We use this wizard to create a project that is based on the SYS/BIOS generic "Hello" example. This example's contents are basically replaced by the CE "universal_copy" example. For this project we use the TI814X target.

The CE example is one that is termed "local", meaning that the codec server runs on the same processor as the application code. This simplifies the project since there is only one executable to build. We choose to build this example for the C674 DSP present on the TI814X device.

The following steps are based upon a Codec Engine "full" installation (as opposed to "lite"), where there is a directory named "cetools" under the root of the Codec Engine repository. (View this article for details about these different "full" and "lite" distributions.) This "cetools" directory contains dependent sub-packages. If you have the "lite" version installed, you will need to add dependent sub-packages instead of adding "<codec_engine>/cetools" in the pertinent step below.

CCS steps

These next steps were done using CCS v4. The project creation layout is different in CCS v5, although equivalent entries can be found.

  1. Create a new CCS "SYS/BIOS" project
    • File->New->CCS Project OR
    • File->New->Other... (opens "Select a wizard" dialog box)
      • C/C++->CCS Project
    • Next > (to "CCS Project" page)
      • "Project name:" CE_project
    • Next > (to "Select a type of project" page)
      • "Project Type:" C6000
      • "Configurations:" Uncheck "Release" and leave "Debug" checked
    • Next > (to "Additional Project Settings" page)
    • Next > (to "Project Settings" page)
      • "Output type:" Executable
      • "Device Variant:" (no <select filter> choice made) Generic C674x Device
    • Next > (to "Project Templates" page)
      • Select SYS/BIOS->Generic Examples->Hello Example
    • Next > (to "RTSC Configuration Settings" page)
      • "XDCtools version:" 3.22.01.21
      • "Products and Repositories" tab - choose what you need, we chose
        • Inter-processor Communication
        • SYS/BIOS
        • XDAIS
      • "RTSC Platform:" click selection arrow, we chose ti.platforms.evmTI814X. The choices available depend on the platforms that are available in the "XDCtools version:" selected above.
      • "RTSC Build-Profile:" debug
    • Finish
  2. Right click your project in the C/C++ Projects tab, select "Add files to Project..."
    • Navigate to <codec_engine>/examples/ti/sdo/ce/examples/apps/universal_copy
    • select main_bios_local.c & app.c & smain.h
  3. Right click hello.c and "Delete" it.
  4. Cut-and-paste contents of <codec_engine>/examples/ti/sdo/ce/examples/apps/universal_copy/local.cfg into hello.cfg (at the very end) and save changes.
  5. Right click your project in the C/C++ Projects tab, select "Build Properties..."
    • For "C/C++ Build" selection...
    • Configuration Settings
      • Tool Settings
        • XDCtools
          • click "Package Repositories"
            • Add <codec_engine>\packages
            • Add <codec_engine>\examples
            • Add <codec_engine>\cetools\packages
  6. "Build Active Project"

The Project Creation wizard walks you through various property pages that are essential for the basic specification of your project. Each of these pages is available via the project's "Properties", which can be selected by right-clicking the project and selecting "Properties".


Here are some screen shots of the Project Creation wizard:

After selecting the File -> New -> CCS Project menu item, choose the SYS/BIOS -> Generic Examples -> Hello Example for a template.

Create project 1.jpg


Select "Next", and then check the "XDAIS" box, select the platform, and change the Build-profile to "debug", as shown in the screen shot below.


Create project 2.jpg