Creating CCS Project using SimpliciTI

From Texas Instruments Wiki
Jump to: navigation, search

The following guides show step by step tutorial to create CCS (Code Composer Studio) project which includes SimpliciTI stack.

Linking the SimpliciTI files to a new CCS project

Creating new CCS v5 Project using SimpliciTI

SimpliciTI projects for CCS are located in:

     <SimpliciTI_root_folder>\Projects\Examples\<target board>
These examples can be used as a base and they can be modified to create your application; or optionally, copies of the projects can be created to start your own.


However, in some cases it might be useful to add SimpliciTI to an existing project or start a project from scratch.

Below is the step by step tutorial to create a new CCS v5 Project which includes the SimpliciTI stack. The tutorial is written just to make a "standalone" version of LinkTo configuration of the Simple Peer-To-Peer example application for MSP-EXP430F5438 (MSP430F5438A) using a CC2500EM module.


  1. Create a new CCS project for MSP430F5438A
    This tutorial shows how to add SimpliciTI to a blank new project but this step can be skipped if a project already exists
    1. Click on File->New->CCS Project
    2. Select a project name
    3. Select mcu variant (in this case MSP430F5438A)
    4. Use the Empty Project template
    5. Click Finish
      CCSV5 1.JPG


  2. Set the DEV_ROOT Variable
    The CCS project will use DEV_ROOT variable as a reference pointing to the SimpliciTI root folder. This variable can be added following the next steps:
    1. Open the project properties (right-click project, select properties)
    2. In Project properties, select Resource->Linked Resources
    3. Click on New
    4. Set name "DEV_ROOT"
    5. Click on Folder
    6. Select the path for the SimpliciTI source folder (in this case "C:\ti\msp430\SimpliciTI_CCS_1_1_1_5xx")
    7. Click OK
      CCSV5 2.JPG


  3. Add the SimpliciTI source files'
    The SimpliciTI files can be added manually to the project, but this simple step adds all files in one step. Note how the files will be "linked" to the project which means that they will still reside in the SimpliciTI installation folder
    1. Click on File->New Folder->
    2. Click "Advanced"
    3. Select "Link to alternate location (linked folder")
    4. Click "Variables"
    5. Select the variable "DEV_ROOT"
    6. Click "Extend"
    7. Select "Components"
    8. Click OK
      CCSV5 3.JPG


  4. Exclude files from build
    The previous step adds all SimpliciTI files including support for all MCUs, target boards and radios. This will cause conflicts in the project which can be fixed by excluding the board/mcu/radio specific files following the next steps
    1. In the CCS Project Explorer select the following folders
      * Components/bsp/boards
      * Components/bsp/drivers
      * Components/bsp/mcus
      * Components/mrfi/radios
      * Components/mrfi/smartrf
    2. Right-click the folders and select "Resource Configuration"->"Exclude from Build"
      CCSV5 4.JPG


  5. Add include paths
    The following include paths must be added to the project
    * Components/bsp
    * Components/bsp/boards/EXP430f5438 (or your specific board)
    * Components/bsp/drivers/
    * Components/mrfi
    * Components/simpliciti/nwk
    * Components/simpliciti/nwk_applications
    Follow the next steps to add each one:
    1. In project options, select Build->Include Options
    2. Click the button to add a new path
    3. Click "Workspace"
    4. Select the appropiate folder
    5. Click OK
      CCSV5 5.JPG


  6. Add predefined symbol for CC2500EM
    This example uses the CC2500EM, so the symbol "MRFI_CC2500" must be pre-defined as follows:
    1. In project options, select Build->Advanced Options->Predefined Symbols
    2. Click the button to add a new symbol
    3. Type "MRFI_CC2500"
    4. Click OK
      CCSV5 6.JPG


  7. Add command and source files to application
    Now you can add your own configuration(.dat) and source files (.c/.h) to your application. You can simply copy-paste them to your project folder, drag-and-drop them to the project explorer or create new ones.
    For this example, we'll simply copy the following files from the SimpliciTI folder to our project:
    * SimpliciTI_CCS_1_1_1_5xx\Projects\Examples\Applications\main_LinkTo.c
    * SimpliciTI_CCS_1_1_1_5xx\Projects\Examples\Applications\app_remap_led.h
    * SimpliciTI_CCS_1_1_1_5xx\Projects\Examples\EXP430F5438\Simple_Peer_to_Peer\CCS\Configuration\smpl_nwk_config.dat
    * SimpliciTI_CCS_1_1_1_5xx\Projects\Examples\EXP430F5438\Simple_Peer_to_Peer\CCS\Configuration\End_Device\smpl_config.dat
    CCSV5 7.JPG


  8. Add the configuration file to project settings
    The .dat files contain configuration symbols used by the SimpliciTI stack. Follow the next steps in order to add them to your project:
    1. In project options, select Build->Advanced Options->Command Files
    2. Click the button to add a new file
    3. Click "Workspace"
    4. Select the .dat files (from previous step)
    5. Click OK
      CCSV5 8.JPG


  9. Build the project
    The project should build without errors now.
    Have fun!!
    CCSV5 9.JPG



Creating new CCS v4 Project using SimpliciTI

Below is the step by step tutorial to create a new CCS v4 Project which includes the SimpliciTI stack. The tutorial is written just to make a "standalone" version of LinkTo configuration of the Simple Peer-To-Peer example application for eZ430-RF2500 (MSP430F2274)


  1. Create a new project for MSP430F2274
    For a tutorial on how to create new MSP430 project on CCS v4, please refer here

  2. Set the DEV_ROOT
    As described in SWRA243 - SimpliciTI Sample Application User's Guide document, set the DEV_ROOT in the CCS Workspace to the default SimpliciTI source folder (usually C:\Texas Instruments\SimpliciTI-CCS-1.1.1) as follows:.
    SMPL NewPrjct Set DEVROOT.PNG


  3. Create the CCS project folder
    Create the CCS project folder for SimpliciTI source files in the following hierarchy.
    SMPL NewPrjct SMPL SrcHierarchy.PNG


  4. Link the SimpliciTI files
    Include the simpliciTI source files by linking them one-by-one (unfortunatelly this is currently the only possibility for CCS v4). The linking should be done by using relative path to the DEV_ROOT path. Linking files in CCS v4 can be done by selecting "File" -> "New" -> "File" -> clicking the "Advanced >>" button -> check the "Link the file in the file system" -> click "Variables..." -> select the "DEV_ROOT" and click the "Extend..." button.
    SMPL NewPrjct Link SMPL Files.PNG

    The following files are to be added:
    * DEV_ROOT/Components/bsp/* to SMPL/bsp
    * DEV_ROOT/Components/mrfi/* to SMPL/mrfi
    * DEV_ROOT/Components/simpliciti/nwk/* to SMPL/nwk
    * DEV_ROOT/Components/simpliciti/nwk_applications/* to SMPL/nwk_applications

  5. Setup SMPL_ROOT macro
    Setup a new project macro SMPL_ROOT also to the default SimpliciTI source folder.
    SMPL NewPrjct Set SMPL ROOT.PNG


  6. Set the include paths
    Set the include path in the project configuration using the SMPL_ROOT macro.
    Below is the list of the paths to be included in the project:
    * ${SMPL_ROOT}/Components/bsp
    * ${SMPL_ROOT}/Components/bsp/boards/eZ430RF (modify if necessary for other platform)
    * ${SMPL_ROOT}/Components/bsp/drivers
    * ${SMPL_ROOT}/Components/mrfi
    * ${SMPL_ROOT}/Components/simpliciti/nwk
    * ${SMPL_ROOT}/Components/simpliciti/nwk_applications
    SMPL NewPrjct Set Include Paths.PNG

  7. Set the pre-define symbol
    Set the predefine symbol of the SimpliciTI platform (in this case MRFI_CC2500 for eZ430-RF2500 with MSP430F2274)
    SMPL NewPrjct Set Predefines.PNG
  8. Add command configuration files and the source files into the project
    Add the necessary command configuration files (.dat) and source files (in this case main_LinkTo.c and app_remap_led.h" from the SimpliciTI source tree). You can just use a windows explorer and do "drag and drop" to copy the files into the CCS project.
    SMPL NewPrjct CompleteProject.PNG
  9. Add the command configuration files into the project setting
    Add the command configuration files into the CCS project settings
    SMPL NewPrjct Set Commandfiles.PNG

After the last step, you should be able to compile the project without errors.

The CCS v4 project can be downloaded here Media:LinkTo_StandAlone.zip

Including the SimpliciTI source code files directly inside a new CCS Project

Please see the following discussion in E2E thread: link