FAQ - CCSv4

From Texas Instruments Wiki
Jump to: navigation, search

The following FAQ's are specific only for Code Composer Studio v4 (CCSv4). Check the CCS FAQ topic for FAQs on CCSv3.3 and earlier.

Contents

Installation

Q: How much space with do I need to install CCSv4 ?

CCSv4 comes bundled with various other components (DSP/BIOS, RTSC, 3P Emulation drivers, etc). A 'Typical Install' will install most of these and will use around 2 GB of space. A 'Custom Install' can be used to choose only the components of interest to reduce the final install size. Note that if you have an existing build of CCSv4 installed and you want to install a new one it is best to install in a new directory, or uninstall the old one before intalling the new one.

Q: Where can I get third party emulation drivers for CCSv4 ?

In v4 we will be including some 3rd party emulation drivers on the installation disk. Essentially those emulators that are sold through the TI eStore (Spectrum Digital, Blackhawk) will have their drivers on the disk to make things easier for initial installation. The drivers for DSKs will also be present.

Q: Can I install CCSv4 on the same machine as CCSv3.3?

Yes you can install CCSv4 in a separate directory without impacting your CCSv3.3 installation. 

Q: Why is the CCS installer preventing me from installing to the folder I selected even though the folder does not exist?

CCS uses an installer product called "InstallJammer". InstallJammer keeps track of previous installations in a folder call the InstallJammer Registry. On Windows, this is located in the folder "C:\Program Files\InstallJammer Registry". If you remove an install without running the product uninstaller, or if the uninstaller does not complete, the registry information for the previous install may be left on the PC. You can manually delete the contents of this folder to clean up the problem.

Q: I received an application error dialog when uninstalling CCS. What should I do?

There is a bug in the version of InstallJammer CCS v4.00 is using, and that can sometimes cause an error dialog to be displayed at the end of the installation. The dialog (pictured below) occurs at the end of the uninstall and can safely be ignored.

CCSv4 FAQ unistall error.jpg

Q: When installing CCSv4, I get a warning message that says that I should upgrade the Java Virtual Machine (JVM) of my default browser because it is older than 1.5.0. Why the warning and what does it have to do with my browser?

In certain cases the older JVM can cause CCS to crash at startup, therefore the warning. Despite CCSv4 installs its own version of the JVM, it attempts to use the default browser's javascript engine to detect network proxy settings to allow CCS updates to work - hence this warning was added.

Q: How do I install the MSP430 Parallel Port FET driver?

There is an option when installing CCS to install this driver, it is disabled by default. If you missed this and have already installed CCS you can go to the installation image that you used to install CCS and go into the \install_images\msp430 folder. This contains the installation program for the MSP430 software. Run this program and provide the path to your CCS installation (you need to include the \ccsv4 on the end, i.e. it will be something like C:\Program Files\Texas Instruments\ccsv4). Select the custom install and check the box for the parallel port driver.

Q: My Stellaris board is not recognized in Windows 7 64-bit. How to solve this?

To date (April 2010) the 64-bit device driver installer that comes with CCS4.1.1 does not install properly, and when the board is connected the device driver is not able to load.

To solve this, connect the board and go to Control Panel --> Device manager; two Stellaris devices should be shown under Other devices.

Stellaris device driver missing.PNG

Right-click on the first Stellaris device and select Update Driver Software.... Select Browse my computer for driver software and point to the directory below. The process must be repeated for the second Stellaris device.

C:\Program Files (x86)\Texas Instruments\ccsv4\emulation\drivers\stellaris\ftdi

Right after this a new device is shown (USB Serial Port) and the process above must be repeated. Depending on how Windows is installed, a reboot may be necessary to perform this step.

Stellaris device drivers installed.PNG

Q: How do I tell if I have the full product or the code size limited (MCU Core) product installed?

When you go to the Help -> About menu if you have the code size limited tools installed it will say "Code Composer Studio Core Edition", if you have the full dvd image installed it will say "Code Composer Studio".

Licensing


Q: Where do I go to get help with licensing?

First check the FAQs here. If that does not solve the problem please try the CCS forum. If you have an issue with an activation code you can email ccs_license_file_help@list.ti.com.

Q: Why do I see license terms for a free license when I install CCS when I purchased a full copy?

CCS will always display the free license terms when you install. However when you activate CCS using the activation code that you obtained when you purchased CCS you will be shown and agree to the license terms that match your purchase.

Q: Why do I see the 30 day evaluation license when I install CCS when I purchased a full copy?

CCS will always display the 30 day evaluation license when you install (unless you downloaded the code size limited tools). However when you activate CCS using the activation code that you obtained when you purchased CCS you will be shown and agree to the license terms that match your purchase.

Q: What happens with a floating license if I go home with a laptop?

If you are configured to check out a license from a license server and you take your computer off the network, CCS will continue to function with no limitation. Note that it will indicate in the title bar that it is currently unlicensed since it was unable to get a license from the server, but otherwise functionality will not be limited. It is not using up a floating license when operating this way.

Q: Where is the link to the 90 day eval license?

For extending the free CCSv4 license to 90 days follow the below procedure:

I) You need to register on TI website.

II) Click on the following link http://processors.wiki.ti.com/index.php/CCSv4_Getting_Started_Guide#Installing_CCS

III) On this web page find "extending license by 90 days" and you will be prompted to login. Login using your user name and password.

IV) Click on “Agree” on first page and then on "next"

V) Then you will be displayed with one activation ID , click on "next".

VI) Then enter you MAC id and click on next. (To obtain the MAC id of your machines go to command line and type ipconfig –all)

VII) Finish the process and you will be getting a license file with extension .lic on your registered email id.

VIII) Start CCS and choose a specify license file and choose the lic file as generated above.

Q: How many computers can I use a node locked license with?

When generating a node-locked license file you can specify 2 MAC addresses (hostids). This allows you to install and run CCS on 2 machines. The license terms state that you cannot be using them at the same time. The purpose of this is if you have a work and home machine or an extra machine in the lab that you need to install CCS on. If you need to run on multiple machines concurrently you should purchase more licenses or consider a floating license pack.

Q: Why doesn't CCS prompt me for a license the first time I run it?

When you run CCS for the first time it will display the license dialog if it cannot find a license. If this dialog is not displayed this means it found a license of some sort. CCS does the actual validation of the license when you launch a debug session and compares the type of session you are launching with your license type. If you have not provided a license and that dialog is not displayed there could be a few reasons for this:

  • You installed CCS from a location that automatically sets up a license file. If you are part of a large team that has a tools admin they may have tweaked the installation to automatically install a license or configure a license server.
  • You may be obtaining a license from a license server and the license server location may have been set by your IT department using an environment variable and CCS picked this up.
  • There was a previous copy of CCS installed on the PC and when that version was run the option to suppress the license dialog was selected. This setting was then picked up by the new CCS installation.

Q: What does this error message mean? "The HOST ID in your license does not match the HOST ID of this computer"

CCS is comparing the host ID of your computer with the one that is in your license file and they are not matching. The cause of this could be that the license was created for a different computer, or you made a mistake when typing in the HOST ID when creating your license or if you have multiple network cards in your computer CCS may be looking at the wrong one. It is possible to re-host your license, please verify the HOST ID of your computer and if you have multiple network cards try entering in 2 HOST IDs when re-hosting your license.

Q: I changed computers how do I update (re-host) my license?

If you go to www.ti.com/myregisteredsoftware you can change the hostid associated with your license file. This is called re-hosting. Note that you can only do this once, after that you need to contact ccs_license_file_help@list.ti.com

Q: Why does the "re-host license" option not show up in myregistedsoftware?

The re-host license option is only available for a limited number of re-hosts. Once those have been used up, it will no longer be available from www.ti.com/myregisteredsoftware. If you need to re-host additional times contact ccs_license_file_help@list.ti.com

Q: Can I use MSP430 with the "free limited license"?

The free license option for eZ430 is the code size limited MCU Core version. You will not be able to use the Free Limited License that comes with the Platinum Download as it is restricted to XDS100, Simulators and non-MSP430 onboard emulation.

Q: Can I use a Spectrum Digital eZDSP board with the "free limited license"?

Yes. The free limited license for EVMs/DSKs/XDS100 will work with the onboard emulation on Spectrum Digital eZDSP kits.

Q: I am a distribution FAE, how can I get a license?

If you are an FAE for a TI authorized distributor you can get a free license. You can either contact your TI distribution rep or you can send an email to ccs_request_fae@list.ti.com Make sure to include your company information.

Q: When I go to myregistered software I see "Not Used" What does this mean?

When activating your license you have an option to specify a description for your host ID. If you leave it blank then you see "Not Used" in the table on www.ti.com/myregisteredsoftware

Q: The Evaluation Option is not available in the license dialog. How can I evaluate CCS?

The evaluation option will not be available if:

  • The evaluation period has expired for the current install
  • There was once a previous installation of CCS that was activated with the evaluation license, and 30 days have passed. Note that the evaluation period is still active even if CCS is uninstalled

In all cases, there is an option to obtain an additional 90 day evaluation license.

Q: Can I upgrade my license to CCSv5?

You will automatically receive a free upgrade to CCS v5 if your subscription was current at the time CCSv5 was released. You can then upgrade your license at www.ti.com/myregisteredsoftware and update a new CCSv5 license file.

If your subscription has expired, you have the option paying the cost of renewing your subscription for the period it has expired or to buy CCSv4, whichever is less.

For users of one of the free CCS licenses (code size limited, time limited, tied to XDS100 or development kit) you can simply download CCSv5 and when you run it for the first time you will be able to generate the equivalent free license for CCSv5.

Q: Can I upgrade my license to CCSv4?

You will automatically receive a free upgrade to CCS v4 in the following cases:

  • Code Composer Studio v3.3 Platinum license with subscription valid to June 1 2009 or later
  • MSP430 Code Composer Essentials v3 Professional license purchased after June 1 2008
  • C2000 Code Composer Studio v3.3 C2000 license purchased after June 1 2008

In each of these cases you will receive an email from TI with an activation code that you would use to register CCS and generate a license file (see licensing section above for details). If you meet the criteria for a free upgrade to CCS v4 and did not receive it by Oct 31, 2009, please contact ccs_license_file_help@list.ti.com. If you never registered CCSv3.3 or CCE then you will need to contact TI with your purchase information so that your upgrade can be processed.

If your subscription has expired, you have the option paying the cost of renewing your subscription for the period it has expired or to buy CCS v4, whichever is less.

Remember that you can download a free evaluation version of CCS v4 that you can try out before making the decision to upgrade.

Current Product Upgrade
CCSv3.3 Platinum Receive CCS v4 + Platinum Node Locked License
CCSv3.3 C2000 Receive CCS v4 + Microcontroller Node Locked License
CCSv3.3 C2000 Free Tools (object code size limited) Download CCS v4 Microcontroller Core image (object code size limited license)
CCEv3 MSP430 Professional Tools Receive CCS v4 + Microcontroller Node Locked License
CCEv3 MSP430 Core Tools (object code size limited) Download CCS v4 Microcontroller Core image (object code size limited license)
CCSv3.3 Free Evaluation Tools Download CCS v4 DVD image (provides an option to generate a 30 day trail license, register for an additional 90 days)
CCSv3.3 DSK/EVM tools (bundled with DSK/EVM/eZdsp) Download CCS v4 DVD image (provides an option to generate a license to work with DSK/EVM/eZdsp bundles)

Q: Can I use my CCSv4.0 license with CCSv4.1?

Yes. Just copy your existing license into \ccsv4\debugserver\license

Q: Can I use my CCSv4.0/4.1 license with CCSv4.2?

Yes. Just copy your existing license into \ccsv4\debugserver\license CCSv4.2 will copy this license into another location in your user folder.

Q: How do I transfer a license to a different user or company?

First, before the transfer can be done the license file must be deleted from the license file directory of the previous user. After that is complete, send an email to TI myRegistered Software support (ccs_subscriptions@list.ti.com). Please include in your email the previous user’s Activation ID and new user’s MAC address and their my.TI email address.

In the case of floating licenses please include the server name if the server needs to be changed. If the server is not changing then mention this in the email and just provided the Activation ID and the user you wish to transfer the license from.

There is a maximum limit of 2 ownership transfers per year. If you have reached that limit, please go to https://estore.ti.com/Software-Development-Tools-C10.aspx to purchase a new Code Composer Studio license.

Q: Why am I getting an error about being unable to connect to a license server when I am not using a license server?

You likely have other products that use FLEXNet licensing installed on your system and one of these products or your IT department is overriding where applications get licenses from. What you can do is copy your CCS license file (.lic) into \ccsv4\DebugServer\license You many also need to create a licenselocation.txt file in this location. Add a line that looks like this to the top of the file: C:\Program Files\Texas Instruments\ccsv4\DebugServer\license You may need to adjust the path to match your installation folder. Make sure that there are no other locations listed in the licenselocation.txt file other than the location of your license.

Note that in CCSv4.2 and later the licenselocation.txt file and .lic files are located in your user folder.

  • Win7 C:\Users\<userid>\AppData\Local\.TI\<some number>\0
  • WinXP C:\Documents and Settings\<userid>\Local Settings\Application Data\.TI\<some number>\0
  • This folder is hidden
  • Each installation of CCS will have its own folder (the "some number" is unique per installation)
  • You can search your user directory for the files.

The reason for this change is that newer versions of windows do not like applications writing the the program files location.

Q: How do I change the license that CCS is using?

You need to do two things.

The license system in CCS caches the license that it is using but you can force it to search for a new license by editing the eclipse.ini file in \ccsv4\eclipse and add the line -DFORCE.REG

Note: in CCSv5 and CCSv6 the file name is ccstudio.ini

You should also edit the licenselocation.txt file and remove the reference to the old license so that CCS doesn't try to use it in the future. In newer versions of CCS this file is in your user folder. Info on where to find this file is available here.

Q: I see an error that says "desired vendor daemon is down" when I try to open the licensing options dialog. What does this mean?

The problem is most likely that there are other FLEXNet licensed products installed on your machine and one of them has set an enviornment variable (LM_LICENSE_FILE) that overrides the application define license location for all FLEXNet enabled applications. If this variable is set and is pointing to a server (or dongle) the underlying FLEX library will think that you want to acquire your CCS licenses from that location. Copying the .LIC file into \ccsv4\DebugServer\License should resolve the issue.

Note that in CCSv4.2 and later the licenselocation.txt file and .lic files are located in your user folder.

  • Win7 C:\Users\<userid>\AppData\Local\.TI\<some number>\0
  • WinXP C:\Documents and Settings\<userid>\Local Settings\Application Data\.TI\<some number>\0
  • This folder is hidden
  • Each installation of CCS will have its own folder (the "some number" is unique per installation)
  • You can search your user directory for the files.

The reason for this change is that newer versions of windows do not like applications writing the the program files location.

Q: Why CCS is complaining that it can't find a feature CCS_ISA_ALL when I launch the debugger?

There could be a couple reasons for this. The most common is that you are trying to use an MCU license with a device that is not supported by this. In CCSv4.0.x the MCU license supports MSP430 and F28x only, in CCSv4.1 Stellaris (CortexM3) and CortexR4 are also supported.

Another reason could be that CCS cannot find your license file at all. Check to see if another application or your IT department has overriden the FlexNET search path by defining LM_LICENSE_FILE. To resolve that you can copy your license file into the location defined by this variable.

Q: How bandwidth intensive is the license check out when using a license server?

We only do license checks in a couple places. Product startup and on debugger launch. So the network traffic involved is very minimal. Thus you could even use the same license server across different offices. CCSv4.1.3 and later further reduce the amount of interaction with the license server.

Q: What happens if the license server goes down or there is a network problem?

Also if for some reason the license server goes down or there is a network issue we still let you use CCS it just says “unlicensed” at the top.

Q: My activation code came with a download link. How do I order the DVD?

If you received an activation code as part of your CCS subscription service it comes with a link to download CCS. If you require a physical DVD you can order one by emailing ccsv4dvd@list.ti.com Please note this offer is not available for people who have purchased a CCS license and selected the cheaper no-DVD option.

Q: How do I activate CCS on a machine without internet access?

Since you are reading this it means that likely somewhere in your company there are machines with internet access. What you need to do is get the MAC address (physical address) of an ethernet card (doesn't even need to be connected to a network, just present) in the machine that you are going to run CCS on. Take this along with your activation code for CCS to the machine with internet access and go to www.ti.com/activatesoftware. This will enable you to create a CCS license file for the machine that is running CCS. Take the file that was emailed to you and drop it in the \ccsv4\DebugServer\License folder.

Q: What happens to CCS when my subscription expires?

CCS comes with 12 months of subscription. This is in no way related to your license to use CCS. If you have purchased a CCS license there is no time limit on how long you can use it. Subscription is used to determine if you receive major upgrades (v5, v6...) for free.

Q: I didn't receive the instructions along with my license file, where can I get them?

Some mail filters may block the license installation instructions from being delivered. There are a few ways that you can install a license file. If you created a node locked license the easiest thing to do is to just copy your license file into \ccsv4\DebugServer\License CCS will automatically look in that folder for licenses.  If you need to setup a floating license on a license server you can get the instructions here: License_Server_Administration_for_CCS

Q: How long is my CCS license good for?

Unless you are using one of the 30 or 90 day evaluation licenses your CCS license is a perpetual license, i.e. there is no time limit on the license.

Q: How do I add a second computer to my node-locked license?

With node-locked licenses you can specify 2 MAC addresses, i.e. you can run CCS on two different machines. You can specify these addresses when initially creating your license or if you need to do it later on you can add a second MAC address using the re-host feature at www.ti.com/myregisteredsoftware

Q: How do I upgrade from the MCU Core (code size limited) tools to the full tools?

The linkers are physically different in the Code size limited tools so you can't just drop in your new license file. You actually need to download and install the CCS Platinum image and drop your new license into that.

Q: Is license "borrowing" supported?

We have not implemented license borrowing in CCS. Borrowing is a license feature where you can reserve or checkout a license from the license server for a period of time. Some vendors require you to do this if your machine is going to be out of contact with the license server. However with CCS we just change the title bar to unlicensed so there is no need to implement license borrowing. If you are going to be constantly running CCS disconnected from your companies network you should consider getting a node locked license.

Q: How do I generate a free license for XDS100, simulator or EVM/DSK use?

In CCS go to the help->Licensing options menu and click the button to "Use free limited license". This will open a browser with the following link. https://focus-webapps.ti.com/licreg/productactivation.tsp?toPerform=firstTimeActivation&orderablePartNumber=TMDSCCS-HWN01A&FNOPartNumber=TMDSCCS-HWN01A-v4.0

Q: Why is CCS still using my eval license after I installed my real license?

CCS will continue to use the eval license until it expires and then will automatically start using your permanent license if you have installed it via the licensing options dialog or by copying it into ccsv4\DebugServer\license Using the eval license does not limit your functionality in any way.

Q: How do I change the license server or port CCS is using?

Edit the licenselocations.txt file in ccsv4\DebugServer\license

Q: Why can't I find the licenselocation.txt file?

CCSv4.0 or CCSv4.1

If you are running on Windows Vista or Windows 7 and you have installed in Program Files or Program Files (x86) then it is possible that you won't be able to find this file. This is due to the fact that Windows will "Virtualize" the Program Files folder. Try looking in C:\Users\<username>\AppData\Local\VirtualStore\Program Files (x86)\Texas Instruments\ccsv4\DebugServer\license. Note that the \AppData folder is likely hidden so just type it in your windows explorer.

If running on Vista or Windows 7 I would recommend installing in a folder other than Program Files.

CCSv4.2 or CCSv4

Note that in CCSv4.2 and later the licenselocation.txt file and .lic files are located in your user folder.

  • Win7 C:\Users\<userid>\AppData\Local\.TI\<some number>\0
  • WinXP C:\Documents and Settings\<userid>\Local Settings\Application Data\.TI\<some number>\0
  • This folder is hidden
  • Each installation of CCS will have its own folder (the "some number" is unique per installation)
  • You can search your user directory for the files.

The reason for this change is that newer versions of windows do not like applications writing the the program files location.

Q: I installed a second copy of CCS on my machine how do I get a license for it?

You can install multiple copies of CCS on the same machine use the same license for all. Just copy the license file from your existing installation into your new one. The license file is in \ccsv4\DebugServer\license

Q: What does "You are not licensed to use the currently-configured connection type" mean?

This message occurs when you are using the free bundled (also called limited) license with a hardware (emulation) connection that it does not support. This license is a free license that enables you to use XDS100, simulators, onboard emulation on DSKs/EVMs/eZdsp boards and Stellaris IDKs (new ones that come with CCS). This license does not allow you to use an XDS510, XDS560 or MSP430.

Q: I see a license file (.lic) in my installation. Can I find out what type or capabilities are enabled?

Yes. In certain cases you can know what type of license you have by the filename:

TMDSCCS-TTTSNNA
  • TTT is the type of license:
HW - Bundled (free limited) license
ALL - Platinum license
MCU - Microcontroller license
  • S is the seating of the license:
N - Node-locked
F - Floating
  • NN is the number of seats of the license:
1 - Single-seat (can be node-locked or floating)
3, 5, 10, 25, 100 - maximum number of seats (25 is platinum-only, 100 is university-only)
  • A Can be the letter A or version number.

If the CCS was provided with a development board or the file was somehow renamed, you can still verify the enabled features: open the license file in a text editor and search if it contains one combination of entries shown below:

CCS_CONNECTION_RESTRICTED - the license is the bundled (free limited) version
CCS_LINKER_LIMITED and CCS_ISA_CONTROLLER - the license is the Free Microcontroller Edition (code size limited)
CCS_LINKER_FULL and CCS_ISA_ALL - the license is the Platinum Edition
CCS_LINKER_FULL and CCS_ISA_CONTROLLER - the license is the Microcontroller Edition

For example, a file TMDSCCS-HWN01A.lic corresponds to a Bundled (free limited) license and inside it would have a feature named CCS_CONNECTION_RESTRICTED.


Q: What advantages a paid license gives me?

The paid license allows using more advanced emulators (XDS510, XDS560, XDS560v2) and its advanced features like System Trace. This in addition to the XDS100 emulators and the ones that are built into development boards.

For MSP430, the advantage is more obvious. The paid license allows using the unlimited version of the compiler, useful for code larger than 16kB.

Q: What does "Port Number is not numeric" mean?

When entering a port number, it is likely there may be a trailing blank after the number. For example, port 27009 entered as '27009 ' instead of '27009'. The port number will unfortunately not be accepted if such a trailing blank exists. Once removed, the wizard should accept the port entry and connect to the license.


License Server Administration


Q: Where are the instructions to setup a license server?

See the License Server Administration for CCS topic.

Q: What does the error "No socket connection to license server manager" mean?

In this case CCS was able to connect to the license server but there is an issue with the daemon that is running. One thing to check is to ensure that the manifest file that is included inside the zip file with the daemon executable was also extracted. If this was not done you will see "unlicensed" in the CCS title bar and if you go to Help -> Licensing Options you will get a dialog box with the error message.

Q: What OS can the license server run on?

Windows, Linux and Solaris are supported.

Q: Can we use a single license server to handle multiple geographic locations?

Yes you could use a single license server to distribute licenses to different locations as long as all locations are on the same network. CCS performs a limited number of license checks and thus does not significant network bandwidth.

Q: Can I run CCS on the same machine that is running the license server?

Yes. One way to achieve this is to edit the first line of the licenselocation.txt file to read @localhost as described in Advanced license configurations

Q: How do I setup a 3 server redundant configuration?

Note that we do not recommend setting up a 3 server redundant configuration for CCS as it is not necessary. It is not necessary since if CCS cannot contact your license server it will still continue to operate and will just inform you that there is a problem. Thus the main purpose of the redundant configuration to protect against a server going down is not necessary. However if you still want to set this up the information on how to do so is below.

When you activate your license specify the name and MAC address of the primary master server. After receiving your license file open it up in a text editor.

Edit your license file so that the top of the file looks like this

#Please Do not delete this comment line.

SERVER <name of primary server> <MAC address of primary Server> PRIMARY_IS_MASTER

SERVER <name of 2nd server> <MAC address of 2nd server>

SERVER <name of 3rd server> <MAC address of 3rd server>

VENDOR tidspssw USE_SERVER

Here is an example:

#Please Do not delete this comment line.

SERVER server1 0000ffee1111 PRIMARY_MASTER

SERVER server2 0000ddee1111

SERVER server3 0000ccee1111

VENDOR tidspssw USE_SERVER


The server names other than the primary server are outside of the signed region of the license file so you can edit this file directly without needing TI to sign the file. It is also possible to change the MAC address associated with each server this way.

Q: I received a second floating license file. Can I combine the two?

Yes. The procedure is similar as if you were adding the first license file in your system.

  • If using Windows, open a web browser and type the URL 127.0.0.1:8080 (if using the default port) to open the license manager GUI. Then follow steps 7 through 10 of the procedure above. Restart the license server for the changes to take effect.
  • If using UNIX command line setup, stop the license server (./lmutil lmdown -vendor tidspssw) and follow steps 6 through 10 of the procedure above.
  • If using UNIX Graphical setup, open a web browser and type the URL 127.0.0.1:8080 (if using the default port) to open the license manager GUI. Then follow steps 6 through 9 of the procedure above. Restart the vendor daemon for the changes to take effect.
    • Depending on the configuration of your system, you may have problems in importing the license due to the lack of write permissions to the licenses/tidspssw directory. Thus you will need to give momentarily write permissions to this directory before proceeding.

Not recommended. If you prefer to merge the two or more license files received, check an interesting discussion in this forum thread on how to do this by directly editing the license file. Be extremely careful when manually editing the files, as this is very error prone. Always make backup copies of your received license files!

If you have multiple license files from different vendors, check Chapter 18 of the The License Administration Guide (located here).

Q: How do I get the license server to start when the machine boots?

If you are finding that on a windows license server the license server is only starting when you are logged in and shuts down when you log out there could be a problem with your settings in LMTOOLS. Run LMTOOLS, go to the "Config Services" tab and make sure that the two check boxes at the bottom are checked.

CCS License Admin Autostart.jpg

Q: I keep getting "CreateProcess error code: 0x36b1 File=tidspssw.exe", why is this?

If this is a Windows machine running the license server the cause could be that you do not have the required version of some Microsoft runtime libraries installed. They can be obtained here. Specifically we need version 8.0.50727.762 of msvcrt80.dll

Q: What does "Port Number is not numeric" mean?

When entering a port number, it is likely there may be a trailing blank after the number. For example, port 27009 entered as '27009 ' instead of '27009'. The port number will unfortunately not be accepted if such a trailing blank exists. Once removed, the wizard should accept the port entry and connect to the license.


Operating System Support


Q: Does CCS support 64bit Operating Systems?

CCS supports XP 64, Vista 64 and Windows 7 64 however the key thing that you need to check is that your emulator vendor provides 64 bit drivers. Below is a status of 64bit driver support:

For the status of 64bit driver support from other vendors please check with the vendor.

NOTE: Some users have seen dialog drawing issues (Some dialogs and views are blank, scroll bars do not work, etc) on 64bit OS. From what we can tell the problem is related to the SWT library used in the version of Eclipse in CCS. Sometimes resizing the dialog and panels can help. See an example of getting the build options to draw correctly. Since the issue is with some conflict with the SWT library and some software running, removing the offending software can also help. Unfortunately there is not a full list of software that can conflict with the SWT library (though everything works fine in 'Safe Mode'). If you are running into this issue, and do not wish to deal with resizing windows all the time, you can try updating the existing SWT library with a newer version that resolves most of the issues:

  • Remove/Rename the 2 existing SWT plugins (org.eclipse.swt*). They are found in '<INSTALL DIR>\ccsv4\eclipse\plugins'.
  • Download and extract the contents of the zip of the new SWT plugins into the above directory
  • Open a command window and browse to '<INSTALL DIR>\ccsv4\eclipse'
  • run 'eclipse –clean' from the command line

The newer SWT library will come by default in 4.2.2. Until then, use the above workaround.

Q: Will CCS support Linux PCs?

There are beta releases of CCS available for Linux. Please check Beta Releases CCS for details and supported devices/emulators.

Q: Is Windows 7 supported?

Yes. We recommend turning off User Access Control (UAC). Note that there are several levels to UAC in Windows 7, we recommend turning it completely off. If you are required to have UAC on make sure to not install in Program Files or Program Files (x86) directories as CCS will not function properly. UAC will block CCS from writing to this folder during operation which will prevent a number of features from working such as the update tool. In general we recommend installing in a folder other than Program Files on Windows Vista and Windows 7 due to UAC and the fact that Windows "Virtualizes" these folders, i.e. makes a copy of them, which can lead to issues in trying to locate files outside of CCS.

Q: Is Windows 2000 supported?

No. CCSv4 and later will not work with Windows 2000.


Updating


Q: How do I get updates to CCS?

CCS will automatically check for updates once a week. You can change the default settings for the check via the preferences dialog. You can also manually check for updates on the help menu.

Q: How do I get compiler updates?

In CCSv4.1 and later CCS will automatically check for updates to the compiler. In CCSv4.0.x you can download updated compiler releases from the compiler site.

Q: How do I get BIOS updates?

In CCSv4.2 and later CCS will automatically check for BIOS updates. In earlier versions of CCS you can download BIOS releases from the BIOS download page.

Q: Why are updates so big?

Updates are cumulative, i.e. they contain all previous content. This is so someone can update to the latest CCSv4 release without having to install a bunch of previous patches. Unfortunately as a result the updates are quite large.

Q: How do I get updates on a machine without internet access?

With CCSv4.1 and forward we will post a zip containing all of the update contents. For earlier releases if you install the updates on 1 machine with internet access the update installers will be located in ccsv4\eclipse\features\com.ti.ccstudio.product_x.y.z.aaaa where x.y.z is the update (i.e. 4.0.2)

Q: When installing CCS updates I get a dailog that warns me that the feature is unsigned. Is this a problem?

No this is not a problem. Prior to CCSv4.1 we do not sign our update files and thus Eclipse will show this dialog. Please click on the Install All button.

Unsignedupdate CCS.png


Migration

Q: Are there any features that were supported in earlier version of CCS that are not supported in CCSv4 ?

Yes. These include:

  • Code Size Tune (was removed prior to CCSv3.3)
  • Cache Tune: Replaced by improved function profiling with cache events.
  • F24x support

Q: Can I use my CCSv3 project with CCSv4?

See: Importing CCSv3 Projects into CCSv4

Q: Can I import multiple CCSv3.3 projects at once?

Yes. In the import wizard choose "Select search-directory" and specify a top level folder that is above the locations of your projects. It will then find all the projects under this folder.

Q: If I buy CCSv3.3 now can I move to CCSv4 for free?

If you have just purchased CCSv3.3 it comes with 12 months of subscription. To receive your CCSv4 license make sure to register CCSv3.3 and then send an email including your service code to ccs_license_file_help@list.ti.com

Q: CCE MSP430 no longer works after installing CCSv4?

CCSv4 includes a newer version of the software that controls the flash emulation tool. If you copy the msp430.dll from CCSv4 (\ccsv4\DebugServer\drivers) into your CCEv3.1 installation it will correct the issue.

Q: IAR embedded workbench for MSP430 no longer works after installing CCSv4?

CCSv4 includes a newer version of the software that controls the flash emulation tool. If you copy the msp430.dll and hil.dll from CCSv4 (\ccsv4\DebugServer\drivers) into your IAR installation it will correct the issue.

Q: Can I still run my GEL scripts?

The majority of GEL scripts will run fine in CCSv4. There are some GEL functions that are no longer supported. Details of GEL support are documented here.

GEL

Q: What is GEL?

GEL stands for General Extension Language, or if you used really old versions of Code Composer GO-DSP Extension Language. It is a C like expression language. It is typically used for device initialization but is also used in other places within CCS where you enter expressions. Details of GEL support are documented here.

Q: How do I load a GEL File?

See: Loading GEL Files

Q: How come my GEL expressions are not being evaluated when I enter them in the 'Console' view?

This tends to happen when either:

  1. Trying to use the console to enter GEL commands while NOT in a debug session
  2. Entering the GEL commands in the wrong console. Make sure you are entering them from the standard Console and not the CIO Console, which are all integrated into one view. You can toggle between the various consoles using the 'Display Selected Console' drop-down menu:

CCS FAQ ccs4 console.PNG

Q: How do I get a GEL file to be automatically loaded when the debugger is launched?

In your target configuration file you can specify an initialization script for each CPU. Open your target configuration file (.ccxml). Click on the advanced tab at the bottom, select your CPU, on the right hand side there will be a field for specifying a startup script. If you want to load more than one script then you can add GEL_LoadGEL() statements to one file to load the others. Place those statements in the Startup() or OnTargetConnect() functions of the first script.

Language Support

Q: How do I enable support for another language in CCS?

Eclipse and hence CCSv4 allows you to install language packs to add support for languages other than english.  The Language Pack Installation topic describes how to install the language packs and how to change the text encoding.

Q: How to prevent CCS from locking up when changing languages?

If you change the Windows language setting while running CCS it is possible to hang CCS. There is a fix in CCSv4.0.2 and later to help with this (Asian languages) however if you still experience the problem you may need to adjust a setting in Windows XP. This is more frequent with Cyrillic languages. Go to Control Panel -> Regional and Language Options -> Languages -> Details -> Advanced. Turn on the option for "Extend support of advanced text services to all programs".

Also, the problem was not observed in Windows Vista or Windows 7.


General

Q: Which version of Eclipse is CCSv4 based on?

CCSv4 is based on Eclipse 3.2. TI has made extensive modifications to this version of Eclipse to make debugging of TI devices easier and more robust. The modifications done by TI are mainly usability related but one key area that impacts compatibility is that we have had to change the debug model, this will impact the ability to integrate other debuggers such as gdb.

Q: With the release of CCSv4 what happens to support for CCSv3.3?

CCSv3.3 will continue to be supported for 12 months after the release of v4. We will switch from doing regular planned service releases to doing service releases as needed to fix critical issues. New device families will only be supported with CCSv4.

Q: When will CCS 4 be available?

CCSv4 has been released on July 20th, 2009 and currently available for download.

Q: How can I reset my workspace?

You can reset your perspective (puts window layout, menu items, buttons back to the default) by going Window -> Reset Perspective You clean your workspace (remove meta data) by adding -clean to the desktop shortcut for starting CCS

Q: Where can I find out about hardware emulators (JTAG probes)?

Additional information about hardware emulators can be found at the below links:

Q: Plug-in 'X' or 'menu-item 'Y' is missing from the GUI! How do I get it back?

Check the Troubleshooting CCS topic when experiencing any strange behavior with the GUI and associated plug-ins.

Q: Can I interface to the TI debug server using GDB commands?

No. We do not provide an GDB interface on top of our debug server.

Q: When will CCS support Stellaris?

CCSv4.1 supports Stellaris.

Q: Does CCSv4 support C24x?

No. The last version of CCS to support C24x is CCSv3.3.

Q: How do I increase the Java heap size for Eclipse?

Open eclipse.ini in \ccsv4\eclipse Adjust the “-Xmx256m“ argument, i.e. bump up to 512m

Q: Some dialogs appear to be blank, what can I do?

On 64-bit Windows there is an issue with the SWT library used by Eclipse. It causes some dialogs to appear blank. See this FAQ for more details.

Q: What is the US Export Classification of CCS?

3D991

Q: Why do I get a Microsoft JScript error when CCS starts?

This error is actually coming from Internet Explorer. The most likely cause is that CCS is reading the internet proxy information from Internet Explorer and Internet Explorer is having an issue and popping up this error. One way to work around this is to disable the automatic proxy configuration in CCS. Go to Window->Preferences, type proxy in the filter box at the top, select Install/Update. Then change the option for the proxy configuration near the bottom of the screen.

Q: Which project files do I need to check into source control?

The following project files should be checked into source control:

  • .ccsproject
  • .cdtbuild
  • .cdtproject
  • .project
  • \.settings folder

.ccsproject has project information specific to CCS.

.cdtbuild, .cdtproject, .project are all Eclipse CDT project files. You can refer to standard Eclipse documentation for more details.

.settings is a standard Eclipse folder that has settings that apply for the project.

The following files and folders should not be checked into source control:

  • \Debug or \Release \<configuration name> folder
  • .xdchelp
  • \.config folder

Configuration folders like \Debug or \Release are generated folders that contain build artifacts like object files and do not need to be checked into source control.

.xdchelp is a generated file that is used to help display error messages in the problems view and does not need to be checked into source control.

.config is a generated folder that does not need to be checked into source control

Q: Is Mathworks software supported with CCSv4?

MathWorks tools do not support the IDE automation in CCS 4.x, but DO support code generation and processor-in-the-loop operation through the use of XMakefile utilities.

See here for more information.

Q: I want to delete some workspaces from the list displayed during CCS launch. Where is the list of recent workspaces stored ?

The list of recent workspaces is stored in the org.eclipse.ui.ide.prefs file found in <install dir>\ccsv4\eclipse\configuration\.settings\.

Q: Is there a simulator for MSP430 in CCS?

No.

Editor

Q: How do I associate a file extension with a file type?

If you want to do something like have *.inc be recognized as a C Header file then follow these instructions:

  • Go to the preferences dialog
  • type assoc in the filter box at the top left
  • select File associations in the tree
  • click on the "Content Types" link at the top
  • Expand Text, expand C Source file
  • Select either C++ source file (if you want to associate with a C or C++ source file) or C Header file (if you want a C header file), for a C++ Header file you need to expand C++ Source file
  • Click the add button
  • Enter in the file extension that you wish to add (i.e. *.inc), click ok

Q: How do select columns in CCS?

The version of Eclipse that CCSv4 is based on does not support column editing (v5 will). However there is a plug-in that you can install which will enable column selection, copy, paste... Go to Help->Software updates, then search for new features and add the following remote update site. Once this is installed you will see additional buttons on the toolbar.

http://columns4eclipse.sourceforge.net/updates

Q: Can I drag-and-drop source files into the editor?

Not by default. But there is an Eclipse plug-in called Filedrag that can be used with CCSv4 to add this support.

Q: How do I specify the editor to auto-save modified source files?

This is not supported by default. But there is an Eclipse plug-in called Save Dirty Editor that can be used with CCSv4 to add this support.

Q: Can the editor support editing of binary files?

Not by default. However there is an Eclipse plugin called Eclipse Hex Editor Plugin (EHEP), which will add this support. If you want to use it to edit .out files you can either rename your .out file to an extension that it recognizes like .hex, .bin, .exe or you can change the editor file associations in Windows->Preferences->Search for editors.

Project Management / Building

Q: How do I specify multiple post build commands? There is only one command field.

You can specify multiple commands in the field. It is the same as running multiple commands on one line in DOS.

See: http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/ntcmds_shelloverview.mspx?mfr=true

Under the topic: Using multiple commands and conditional processing symbols

Q: How do I specify CCS to use a different version of the Code Generation Tools?

See Compiler Installation and Selection.

Q: Why do I get "Command Line Error - Missing Source File Name" when building my project?

This is most commonly caused by a macro being used in the build options that is not defined. This macro then gets resolved to an empty string and you will see "" in the build command line. Check your build options, especially the include directories to see if any of them are using a macro that is not defined. Macros like {CCS_INSTALL_ROOT} and {CG_TOOL_ROOT} are defined by CCS. User macros are defined on the Macro tab of the build options dialog. Click on this tab and then select project.

Q: How do I get CCSv4 to recognize (and build) a new source file type extension?

To associate a new source file type with CCSv4, Select 'Window->Preferences' and expand 'C/C++' subtree and go to 'File Types'. Click on 'New' and add the new extension and specify the file type:

CCSv4 FAQ file types.PNG

Q: I accidentally deleted a file in my project from CCS and it does not appear in the Recycle Bin. How do I get that file back?

Eclipse does not use the system recycle/trash bin when deleting a file. However it does keep its own backup in the local history. You can restore the file from the local history by right clicking on the project folder and selecting "Restore from Local History".

Debugging

Q: What does 'data verification error' mean?

See: Troubleshooting_CCS_-_Data_Verification_Errors

Q: When I try to halt execution of my running application, why does my debug session shut down?

You are most likely hitting the 'terminate' button (looks like some red squares) and not the 'halt' button (which looks like a standard 'pause' button). The 'terminate' button will terminate (shut down) your debug session. The 'halt' button will pause execution of your application (similar to the 'halt' command in earlier versions of CCS. In the screenshot below, two buttons are circled. The one on the left is the 'halt' button and the one on the right is the 'terminate' button:

CCSv4 FAQ debug halt.JPG

Q: Where is the 'Call Stack'?

It is integrated into the 'Debug' view. See slide 15 of the CCSv4 Tutorial.

Q: I got an "Error connecting to the target: Error 0x80000240/-151 Fatal Error during: Initialization, OCS" when trying to connect to the target

Xds100v1poderror.jpg

Q: Where are the icons/buttons for target execution (step, run, halt, etc)?

They are available from the 'Debug' view. If you cannot find the 'Debug' view, you may have accidentally closed it (see next FAQ).

Q: My 'Debug' view is gone! Where did it go?

You most likely closed the 'Debug' view during your debug session (and ignored the warning/info message that popped up since you are asking this question). Most people incorrectly assume that closing the 'Debug' view will terminate the debug session but this is not true. It simply closes the view. Since the 'Debug' view is an integral view for the debug session, you will want it back. You can bring it back by going to the main menus and selecting 'View->Debug'. And next time, try not to ignore important messages for CCSv4! :-)

Q: I've successfully started a debug session but most of the target operations under the 'Target' menu are grayed out. How do I get access to them?

This is most likely because you closed the 'Debug' view (see the previous FAQ), hence CCS does not have an active debug context. Reopening the 'Debug' view will make those target operations available again.

Q: Why do I get an error "Failed to initialize the Debug Server... xml contains invalid character?

Either your workspace or your project path contains a special character. For example you might have a character like this "é" in the path. To workaround this problem choose a new workspace location without any special characters in the path.

Q: Why do I get a "Cannot enable while the target is running" error when I try to enable a breakpoint? I was able to do this in CCSv3!

The default behavior of CCSv4 will prevent any debugger access that will cause an unintended halt on a running target. An example of this is enabling a breakpoint. To change the default behavior to mimic CCSv3 default behavior of automatically halting the target (when needed) and resuming execution, use the option available under 'Tools->Debugger Options->Realtime Options' and enable 'Halt the target before any debugger access:

CCSv4 FAQ realtime.PNG

Q: Why are some devices like ICEPick and DAP missing from the 'Debug' view?

The 'Debug' view hides non-debuggable devices from view by default. This is to reduce clutter in the view. If you wish to have these devices show up, browse to: 'Windows->Preferences...->CCS->Debug' and enable the first option: 'Show non-processor devices (i.e. routers like ICEPick and DAP)

CCSv4 FAQ debug routers.PNG

Q: What happened to mixed-mode view where I can interleave assembly with the source?

Mixed mode is now supported in the 'Disassembly' view. Right-click in the 'Disassembly' view and select 'Show Source' in the context menu.

Q: Where are the options for Realtime Mode?

The options are available from the 'Generic Debugger Options' dialog (Tools->Generic Debugger Options):

CCSv4 FAQ RTM.PNG

Q: How do I change the Realtime Mode refresh rate?

The options to do this are under CCS Debug Preferences (Window->Preferences->CCS->Debug->Continuous refresh interval (seconds)):

CCSv4 FAQ RTM refesh.PNG

You cannot select a value smaller than 1 second in CCSv4.0

Upcoming Enhancements: In CCSv4.1, you will be able to choose smaller values for the graph windows only.

Q: Nothing happens when I click Debug Active Project

One possible cause of this is that the there is no debug launch configuration associated with the project. Debug launches are something that Eclipse uses that we have abstracted in CCS. What you can do is manually recreate this association. Click on the down arrow beside the Bug icon. Select "Debug...". This will open the Debug configuration dialog. At the bottom of the tree on the left hand side you should see a node called "Project Debug Session". If you see an item here that has the same name as your project then select it and hit delete (you may not see one). Next we need to create a new configuration. Right click on "Project Debug Session" and select "New". Name the configuration such that it matches your project name, enter the name in the edit box beside "Name:" We need to associate the launch with a project so beside the project field click on the browse button and select your project. We also have to specify the program to load, click on the search project button and select the program to load. If you are working with a multiple CPU board you need to click on the Debugger tab and select which CPU to load the program on, if not then you are done. Click on the Apply button and the click Close.

Debug Active Project should now work.

Q: What are debug launches and where are they stored?

A debug launch is something that CCS caches when launching a debug session for the first time for that specific target configuration. Debug launches are stored in your workspace folder: <WORKSPACE>\.metadata\.plugins\org.eclipse.debug.core\.launches

Profiling


Q: How come there are no activities to enable in the 'Profile Setup' view?

If there are no options available under the Activities list, then it means that CCS profiling is not supported for that target.

Q: What targets support CCS function profiling?

  • hardware (C55x, ARM7, ARM9)
  • simulator: Please check this chart to see which simulators support it
  • Alternatives are to use the profile clock or to use PC Trace on enabled devices

Q: Why is function profiling not supported on C6000 hardware?

C6000 devices are cache based. The standard function profiler in CCS works by setting breakpoints on branches. Thus on a cache based device your profile data will be largely skewed by the extra cycles that occur due to the cache being evaluated. Also on C6000 it is not possible to set more than one breakpoint in an execution packet, however there could be multiple branches in an execution packet which would cause issues with profile data.

For C6000 it is recommended to use the simple profile clock or instrumentation to profile. Alternative you can use PC trace.

Q: What targets support CCS code coverage?

  • Only a select number of simulators support CCS code coverage. Please check this chart to see which simulators support it. It is not supported on any hardware target.