Please note as of Wednesday, August 15th, 2018 this wiki has been set to read only. If you are a TI Employee and require Edit ability please contact x0211426 from the company directory.

GSG:Importing projects from previous versions

From Texas Instruments Wiki
Jump to: navigation, search

Importing projects from previous versions


Importing a project from Code Composer Studio 3.x releases

Previous releases of Code Composer Studio use project files (*.pjt) that contain all build options and references to source files, while CCSv4 uses a new project format that automatically builds every valid source file located in the project directory and stores the build options in several files and directories starting with a dot.

Because of these differences, CCSv4 provides an Import Legacy CCS Project Wizard to help with the migration.

Important! The migration is not always perfect and there may be some manual tweaking to the generated project afterward to fix any migration issues, especially if your project was originally designed for CCS versions older than 3.3. The next section discusses some of the most common issues.
Important! The original legacy project must stay in a directory other than the workspace directory for the import tool to work properly.
Note: for a complete list of the differences between CCSv3.3 and CCSv4, please see
http://processors.wiki.ti.com/index.php/Migrating_to_CCSv4

Running the Wizard

1. Launch the wizard by selecting Project --> Import Legacy CCSv3.3 Project

Fig. 1: Import Legacy CCS Project Wizard Menu


2. Specify the CCSv3 *.pjt file to import. Click on Select a Project File: and click on Browse... to choose the .pjt file to be converted.

  • Enabling the Copy projects into workspace checkbox will copy the project and associated files into the CCSv4 workspace. This is good to keep the original project intact.
  • Some example projects (C2000 examples installed in C:\tidcs, Stellarisware, NDK) have several dependencies in directories relative to the original project location. In this case it is better to select Keep original location for each project and keep the relative paths intact.
Optional: Multiple projects can be converted at once. Choose Select Search-directory: and click on Browse... to select a folder that will be recursively scanned for CCSv3 projects to import. Any eligible projects that can be imported will appear in the Discovered legacy projects list.
Fig. 2: Importing a single project
Fig. 3: Importing multiple projects


3. Next screen allows selecting the Code Generation Tools version to use. In most cases this can be left with the default version supplied with CCSv4. Click Next.

Fig. 4: Selecting Code Generation Tools version


4. Specify which DSP/BIOS version to use. In most cases this can be left with the default version supplied with CCSv4. Click Finish

Important! it is mandatory to use the default version if you intend to use the BIOS debugging tools: Real-Time Analysis (RTA) and the Real-time Object Viewer (ROV) - the replacement of Kernel Object Viewer.
Note: if the original project uses a DSP/BIOS release older than 5.x, it must be converted by DSP/BIOS 5.x converter tool before migrating to this new version. Reasons and details about this migration can be seen at the page below:
http://processors.wiki.ti.com/index.php/Migrating_from_BIOS_4.9_to_BIOS_5.x
Fig. 5: Selecting DSP/BIOS version


5. After the wizard finishes the conversion process the newly generated CCSv4 project will appear in the workspace.

Importing a project from CCE or previous releases of CCSv4

Although CCE and all versions of CCSv4 share the same project format, Eclipse still requires importing these projects in order to keep dependencies consistent to the current installation - things like include directories, tool versions, etc.

Important! Although tempting, simply copying the projects to the workspace is not recommended.


Running the Wizard

1. The process is very similar as importing the project in the first section. Go to menu File --> Import Existing CCS/CCE Eclipse Project.


2. Two ways of importing projects are available.

  • To import one or more projects located in an existing directory, select Select root directory option. Click Browse to select the directory that contains the project directory. Any valid projects will be shown in the Projects: box:
Fig. 6: Select project directory
  • To import one or more projects located in a zip file, select Select archive file: option. Click Browse to select the .ZIP file that contains the projects. After selecting the file, any valid projects will be shown in the Projects: box:
Fig. 7: Select project archive


Additional steps that may be required

Sometimes the migration process may require your attention to fix specific aspects that the wizard would not risk changing itself.

In most cases the changes required are located inside source or linker command files; since the wizard adopts a conservative approach in the migration process, it avoids directly modifying these types of files.

1. For example, the message box below will be displayed and the file <migration.log> is located in the project directory. It is highly recommended to open this log and check for any issues.

Fig. 6: Migration Warning


2. Some projects in CCSv3.3 have implicit include directories that are automatically imported and cause build errors. In these cases, it is important to remove these paths by going to menu Project --> Properties and check the include directories under either Compiler --> Include Options or Linker --> File Search Path.

In the example below, the compiler seems to have include directories of two versions of the Chip Support Library (CSL).
Fig. 7: Project Build Error - Console


What's next?

Now that you have finished importing your existing project into Code Composer Studio v4, please continue on to the Project Debugging section of the CCSv4 Getting Started Guide.


CN GSG:Importing projects from previous versions