Please note as of Wednesday, August 15th, 2018 this wiki has been set to read only. If you are a TI Employee and require Edit ability please contact x0211426 from the company directory.

HET IDE

From Texas Instruments Wiki
(Redirected from High End Timer IDE)
Jump to: navigation, search
HET IDE Screenshot.JPG


Note: This page is under development.


Description

The High End Timer Integrated Development Environment (HET IDE) is a windows application that can be used to configure and simulate the HET and NHET Timer Co-processors from Texas Instruments.

The HET IDE is an easy way to get started developing and debugging code for the High End Timer.

The HET IDE has 3 main components: the Graphical User Interface for ease of use, the NHET simulation kernel and the integrated waveform viewer from SynaptiCAD. The HET IDE performs best when using the FREE 90 day license of WaveFormer Pro from SynaptiCAD.

The simulation kernel provides full visibility and breaking capacity which are not possible on silicon samples. The waveform viewer is SynaptiCAD's Waveformer Pro and is a professional tool for waveform creation and visualization.

Overview Video

"Click here for a video showing an overview of the IDE and its features"

Features

  • Create and save dedicated projects with for a specific device configuration
  • Edit and save configuration registers
  • Create complex breakpoints on pin events or memory field comparisons
  • Create and save input timing waveforms from external stimuli
  • Drag and drop NHET instructions for easy code development
  • Algorithm Library with code samples
  • Straightforward simulation environment with full visibility of the NHET status
  • Memory write triggers on time, cycle, pin event and interrupt
  • Cycle Count and simulation time display

GUI Explanation

The HET IDE GUI is separated into two views:

1. Edit View

  • Enabled when the simulator is stopped
  • Able to edit HET code

2. Run View

  • Enabled when the code is assembled/loaded
  • Able to control simulator
  • View simulation results in SynaptiCAD WaveViewer or WaveFormer.

Creating a New Project

To create a new HET IDE project:

  1. Click Project > New Project.
  2. Type a Project Name.
  3. Use the browse button to select the folder where the project will be stored.
  4. Click Next.
  5. Select the device configuration that will used by the simulator.
  6. Click Next.
  7. Enter the oscillator value into the Clock frequency box.
  8. Click Next.
  9. Type a name for the .het file into the first box to start with a blank .het file. Otherwise, enable the checkbox and select an existing .het file.
  10. Click Next.
  11. Review the Project Properties.
  12. Click Finish.

Once the new project is created, it will appear in the project explorer on the left-hand side of the screen and the .het file created with the project is open in the center of the screen. Also, the device information is displayed on the right-hand side of the screen.

Integrating HET IDE Files with CCS4

1) Create a new HET project by following the steps in the #Creating a New Project section above.

2) Insert assembly code into the .het file.

NOTE: Example code is available in three locations:
1) Tutorial files included with the installation of HET IDE
2) HET IDE menu: Edit --> Insert Algorithm
3) #Sample Projects section of this wiki article

3) (Optional) Verify the operation of the assembly code in the simulator.

a) Assemble and load the code by going to Debug --> Assemble and Load.
b) Minimize the SynaptiCAD window.
c) Run the simulator be going to Debug --> Run.
d) Stop the simulation.
e) View the waveform in the SynaptiCAD software that opened when the code was loaded.
f) If modifications are necessary:
i) Restart the simulator by going to Debug --> Restart Simulator.
ii) Edit the .het file and return to step 3a in this process.

4) Generate a project using HalCoGen to configure the HET module.

a) Open HalCoGen.
b) Go to File --> New Project.
c) Fill in the fields on the screen to create the new project.
d) In the Driver Enable tab, be sure to enable the HET driver. Other drivers may be enabled as well.
e) In the Clock Tree tab, verify the Oscillator frequency
f) In the HET --> HET Global Configuration tab, change the HR Clock and Loop Time fields so that the HR and LR fields match the values in the HET IDE project.
NOTE: The HalCoGen HR value is actually the power of two equivalent of the HET IDE value. For example,
HalCoGen HR Prescale = 4
HET IDE HR = 2^4 = 16
g) In the PWM 0-7 tab, enable as many PWM signals as there are pins used in the HET IDE. Be sure to change the pin number in the Pin dropdown menu in HalCoGen.
h) In the Pin 0-7...Pin 24-31 tabs, configure the PWMs pins as outputs by clicking the top checkbox in the Dir section.
i) Save the project by going to File --> Save Project
j) Apply the settings made in HalCoGen by going to File --> Generate Code.
k) Close HalCoGen.

5) Open the project using CCS.

a) Open CCS4.
b) Create a new project with the same name and in the same directory as the HalCoGen project.
i) Go to File --> New --> CCS Project.
ii) Enter the HalCoGen project name in the Project Name box.
iii) Verify that the workspace is pointing to the correct directory.
iv) Click Next three times and click Finish.
c) Click the C/C++ button on the upper right-hand side of the GUI.
d) The code should now appear on the left-hand side of the GUI.

6) Modify het.h to accept the instruction structure generated by the HET IDE.

a) Double click the het.h file in the CCS file structure.
b) Modify the hetInstructionBase variable to look like this:
typedef volatile struct hetInstructionBase
{
unsigned Program;
unsigned Control;
unsigned Data;
unsigned Dummy;
} hetINSTRUCTION_t;

7) Replace a portion of the code in het.c with assembly code generated with HET IDE.

a) Double click the het.c file in the CCS file structure.
b) Delete the contents of the hetPROGRAM[]array.
c) Switch to the HET IDE.
d) If in edit mode, assemble and load the code.
e) Copy the contents of the array defined in the C File tab.
f) Paste this code into the hetPROGRAM[]array in CCS.

8) Compile and run the code.

a) Ensure that a device is connected to the PC.
b) In CCS, click the Debug button.
c) From the debug view, the code can now be run on the device.

9) If any modifications need to be made to the .het code, the changes should be made in the HET IDE and copied into CCS as described in step 7.

10) If any modifications need to be made to the HalCoGen code:

a) Repeat the actions described in Step 4.
b) The project should be reopened in CCS.
c) Step 6, 7, and 8 should be completed.

Sample Projects

SynaptiCAD WaveViewer Free

SynaptiCAD WaveViewer Free is installed with the HET IDE. The operations highlighted by the red box in this image are not available in this software. However, the #SynaptiCAD WaveFormer Pro licensed version of the software enables these operations.

WaveViewer Free.JPG

SynaptiCAD WaveFormer Pro

To apply for a WaveFormer Pro license, fill out the registration information on the webpage that appears at the end of the installation process.

WaveFormer Pro.JPG

Documentation

Support

Feel free to post a question on the TMS570 forum for support: TMS570 Forum

Important Links