How to setup Remote System Explorer plug-in

From Texas Instruments Wiki
Jump to: navigation, search

Return to the Sitara Linux Software Developer's Guide

Overview

Remote System Explorer (RSE) is an Eclipse plug-in that provides:

  • Drag-and-drop access to the remote file system
  • Remote shell execution
  • Remote terminal
  • Remote process monitor

Prerequisites

Before you configure RSE you should make sure the following prerequisites are met:

  1. The RSE capability is enabled
  2. The EVM you plan to connect to is powered on and you know the IP address of the EVM.
    • You can obtain the IP address of the EVM using matrix and selecting Settings -> Network Settings or by connecting over the serial console and using the ifconfig command.

The first time this plug-in is used, a connection to the target EVM needs to be established and configured. Follow the procedures below to setup and configure RSE for use with the Sitara Linux SDK.

Opening the Remote System Explorer Perspective

  1. Go to Window -> Open Perspective -> Other...
  2. In the menu window select Remote System Explorer to open this perspective.
    NOTE: If Remote System Explorer does not appear in this list you need to enable additional CCS capabilities
    Sitara-Linux-CCS-rse-perspective.png
  3. Click OK
  4. You will now have the RSE view opened
    Sitara-Linux-CCS-rse-view.png


Creating a New Connection

To establish a new connection with the target EVM you must run the New Connection Wizard.

  1. Click File -> New -> Other...
  2. In the Select a wizard window select Remote System Explorer -> Connection
    New-connection.png
  3. Click Next
  4. In the Select Remote System Type window select the Linux system type
    Remote-system-type.png
  5. Click Next
  6. In the Remote Linux System Connection window enter
    Host name: Enter the IP address of your target EVM. This can be determined as detailed in the Prerequisites section above
    Connection name: The default value is the same as the host name, but this can be changed to a more human readable value like My Target EVM
    You can un-check Verify host name or leave it checked depending on whether you want to verify the IP address you entered for the Host name field.
    X-New Connection.png
  7. Do NOT click the Finish button.  Click Next
  8. Check ssh.files to use the Secure Shell protocol for communication
    Ssh-files.png
  9. Do NOT click the Finish button.  Click Next
  10. Check processes.shell.linux to use a shell to work with processes on the remote system
    Processes .png
  11. Do NOT click the Finish button.  Click Next
  12. Check ssh.shells to use Secure Shell to work will shell commands
    Shells.png
  13. Do NOT click the Finish button.  Click Next
  14. Check ssh.terminals to use Secure Shell to work with terminals
    Terminals.png
  15. Click Finish
  16. You will now see your EVM configuration in the RSE view
    Sitara-Linux-CCS-target-view.png

Re-Opening the C/C++ View

If when you enabled RSE and opened the RSE perspective your C/C++ view disappeared you can re-open it using the following commands. This is useful to get back to your projects list to enable copying and pasting files to transfer to the remote system as detailed in the Transferring Files section below.

  1. Select Window -> Show View -> Other...
  2. In the Show View dialog select C/C++ -> C/C++ Projects
    Sitara-Linux-CCS-c-view.png
  3. Click OK
    • NOTE: If you do not like the location of the C/C++ Projects view you can drag it to another location in CCS my dragging and dropping the Tab.

Re-Opening the Remote System Explorer View

If you have closed the RSE view and wish to re-open it you can use these steps:

  1. Select Window -> Show View -> Other...
  2. In the Show View dialog select Remote Systems -> Remote Systems]]
    Show-view-remote-systems.png
  3. Click OK
    • NOTE: If you do not like the location of the Remote Systems view you can drag it to another location in CCS my dragging and dropping the Tab.
  4. A Remote Systems tab appears in the CCS perspective. The target connection named My Target EVM is shown in a tree structure with branches for the various Remote System functions which communicate with the target EVM using a secure SSH connection.
    Sftp Files - Provides a drag and drop GUI interface to the target file system.
    Shell Processes - Provides a listing of processes running on the remote system and allows processes to be remotely killed.
    Ssh Shells - Provides a Linux shell window for the remote system within CCS.
    Ssh Terminals - Provides a terminal window for the remote system within CCS.
    Sitara-Linux-CCS-target-view.png

Configuring the Target EVM Connection

After the New Connection Wizard has been completed and the Remote System Explorer view has been opened, the new connection must be configured to communicate with the target EVM.

  1. Right-Click on the My Target EVM node and select Properties from the context menu.
  2. In the Properties window click on Host
  3. Change the Default User ID: to root
    X-change-user-id.png
  4. Click OK

The Remote System Explorer is now ready for use. The first time the target EVM file system is booted a private key and a public key is created in the target file system. Before connecting to the target EVM the first time, the public key must be exported from the target EVM to the Linux host system. To configure the key do

  1. Right-Click the My Target EVM node and select Connect
  2. A dialog like the one shown below will appear
    Setup-ssh-editted-1.png
  3. Click Yes to accept the key

Under certain circumstances a warning message can appear when the initial SSH connection is made as shown below. This could happen if the user deletes the target file system and replaces it with another target file system that has a different private RSA SSH key established (and the target board IP address remains the same). This is normal. In this case, click Yes and the public key from the target board will be exported to the Ubuntu host overwriting the existing public key.

Nasty-Warning-2.PNG


At this point, all Remote System Explorer functions will be functional.; After this, each time CCSv5 is started, the first time a Remote System Explorer function is accessed, a login prompt will appear. Just click OK and leave the password blank.

NOTE: You can save the blank password and bypass any future prompts as well.

Configuring with a Proxy

In the case that you are behind a proxy you may need to configure CCS to use this proxy information to connect to remote servers. However, you want to make sure you also bypass the proxy for your target devices so that your connection does not attempt to go out the proxy and then come back in through the proxy. To configure the proxy you can do:

  1. Click the Window -> Preferences menu item
  2. Go to General -> Network Connections
  3. Change the Active Provider from Native to Manual
  4. Highlight the HTTP item and click the Edit button
  5. enter your company's host proxy URL and port number
  6. Do the same for the HTTPS item. Both items should be checked as shown below.
    X-network-Connections-top.jpeg
  7. In the Proxy Bypass section click Add Host...
  8. Add the IP address of target board (in place of xx.xx.xx.xx)
  9. Click OK.
    X-network-Connections-bottom.jpeg

Using Remote System Explorer

If Remote System Explorer is not included in the current CCS perspective using the steps at Re-Opening the Remote System Explorer View section above.

If prompted for a login use root for the user ID and leave the password blank. NOTE: you can save the user ID and password values to bypass this prompt in the future

X-login.png

Target File System Access

Expand the Sftp Files -> Root node. The remote system file tree should now show the root directory. You can navigate anywhere in the remote file system down to the file level. Files can be dragged and dropped into the remote file tree. A context menu allows you to create, rename or delete files and folders.

Expand-root-small.jpeg

The local file system on the Linux host can also be accessed by expanding the Local -> Local Files node.

SSH Terminals

To open an SSH Terminal view

  1. Right-Click the Ssh Terminals node under the target EVM connection
  2. Select Launch Terminal from the context menu
  3. Type shell commands at the prompt in the terminal window. Below is a sample command to list the contents of the remote /usr folder.
    MyTerminalView-small.jpeg 

SSH Shells

To open an SSH Shell view

  1. Right-Click the Ssh Shells node under the target EVM connection
  2. Select Launch Shell from the context menu.
  3. Type a shell command into the Command edit box and press the Enter key. Below is the output from the ps command which displays the processes running on the remote system
    MyShellView-small.jpeg

Shell Process Monitor

To open the Shell Processes view

  1. Right-Click the Shell Processes node under the target EVM connection
  2. Select Show in Table from the context menu
  3. Double-click All Processes to see the list of processes running on the target
    • By clicking any column header, the list can be sorted by the parameter in the selected column, such as executable name, memory size, or PID
    • You can Right-Click on a particular process and click Kill in the context menu to kill a process.
    MyProcessList-small.jpeg

Archived Versions