Source control with CCS

From Texas Instruments Wiki
Jump to: navigation, search

This document is now maintained here

Files to check in

One of the first questions that come up when working with source control and CCS is which CCS project files need to be checked in to source control.

CCSv5 and greater

The following project files should be checked into source control:

  • .ccsproject
  • .cproject
  • .project
  • .settings folder
  • makefile.defs (if using SYS/BIOS)

.ccsproject has project information specific to CCS.

.cproject and .project are Eclipse CDT project files.

.settings folder is a standard Eclipse folder that has settings that apply for the project.

makefiles.defs has additional make rules included by the generated project makefile for SYS/BIOS projects.


The following files and folders should not be checked into source control:

  • \Debug or \Release \<configuration name> folder
  • .xdchelp
  • \.config folder
  • \.launches folder

Configuration folders like \Debug or \Release are generated folders that contain build artifacts like object files and do not need to be checked into source control.

.xdchelp is a generated file that is used to help display error messages in the problems view and does not need to be checked into source control.

.config and .launches are generated folders that do not need to be checked into source control.


For target configuration files or targetConfigs folder: If the project is configured to "Manage the project's target-configuration automatically" and the default settings in the generated ccxml file are not changed, then it is optional to check it into source control (as it will get auto-regenerated if missing). But if the ccxml file is being managed manually, or modifications were made to the default settings in the auto-generated one, then it is advisable to check it into source control.



CCSv4

See this FAQ.

Source control Integration

CVS and GIT

There is more information on using Git with CCS here: Resource Explorer article on Git


CCSv5 and greater has native support for CVS and GIT so you can browse repositories, check in/out files, get history, etc all from within the GUI.
To use CVS with CCSv6, however, you must first install its support via the CCS App Center. Simply go to menu View --> CCS App Center. From there, type in CVS in the search box, select Install and follow the instructions. You will have to restart CCS.

CVS in CCS App Center.png


You can explore the CVS and GIT repository from CCS menu Window->Open Perspective->Other, enable Show All, and select CVS Repository Exploring or Git Repository Exploring.
More information on working with CVS and Git can be found in the CCS Online Help.

Git perspective.png


Plug-ins are available from the Eclipse Marketplace for some other source control providers such as ClearCase, SourceSafe, SVN.
When searching for plug-ins, make sure to look for ones that support the same version of Eclipse that your version of CCS is based off of for best compatibility (CCS 5.1 and 5.2 are based off Eclipse 3.7, CCS 5.3+ is based off Eclipse 3.8 and CCSv6.0 is based off Eclipse 4.3).



Github

For Github, the e2e user Glenn Vassallo kindly created step-by-step instructions in this post. These instructions are reproduced below:

Cloning a Github Repository to use CCS:

  1. Install Github for Windows from here - https://windows.github.com/
  2. Start CCS and select an existing workspace or create a new workspace
  3. Go to the Github repository you wish to use and click on Clone in Desktop
  4. When prompted select Launch Application to allow Github for Windows start
  5. In the browse dialog box, located the Workspace you selected in step 2 and press ok
  6. Wait for the Cloning process to complete
  7. Go to CCS and select Project menu and Import CCS Project option
  8. Press the Browse button for Select search-directory
  9. Then browse to the Workspace and press ok
  10. Make sure you tick the project you just cloned
  11. Do not check either “Automatically import referenced projects found in same directory” or “Copy projects into workspace”
  12. Press the Finish button
  13. You should now have a working Git repository in your workspace

Using Git and GitHub in CCS

  1. Right click on the project and select Team
  2. The Commit to Commit
  3. Pull to get the latest from the Github Repository
  4. Remote - Push to publish latest update to Github Repository




Installing Plug-ins

You can install Eclipse plug-ins by one of these methods:

  • Use the Eclipse Update Manager
    • CCS menu Help -> Install New Software, then specify remote site (URL) or local site (directory)
  • Use the Eclipse Marketplace
    • CCS menu Help -> Eclipse Marketplace
  • Drop-in into CCS installation
    • Many plug-ins can simply be downloaded as an archive and copied into the .\ccsv5\eclipse\dropins folder


The CCS Plugins category has more information on installing some plugins that are known to work with CCS.