Talk:Getting Started with the Stellaris EK-LM4F120XL LaunchPad Workshop

From Texas Instruments Wiki
Jump to: navigation, search
For technical support please post your questions at http://e2e.ti.com. Please post only comments about the article Getting Started with the Stellaris EK-LM4F120XL LaunchPad Workshop here.

Comments on Getting Started with the Stellaris EK-LM4F120XL LaunchPad Workshop


Dermahr said ...

http://software-dl.ti.com/trainingTTO/trainingTTO_public_sw/GSW-Stellaris-LaunchPad/StellarisLaunchPadWorkbook.pdf

Seems to be broken, tried downloading it several times.

--Dermahr 18:34, 20 September 2012 (CDT)

Notsane said ...

I'm still getting everything in its final location. Official release is 9/25

--Notsane 18:55, 20 September 2012 (CDT)

Toddintr said ...

In Lab 2, the folder C:\StellarisWare\boards\MyLaunchPadBoard\Lab2\ccs is not in the StellarisWare installation (I have version 9453 installed). Because of this, the startup_ccs.c file is not created.

Also, there is no "+" sign next to Lab2 in Eclipse, seems that it is now an right facing arrow sign.

--Toddintr 16:29, 6 October 2012 (CDT)

Westfw said ...

(In general, I'm finding this Workshop to be very nice. Pleasantly deeply technical, with a bunch of useful content, well presented in a way that highlights a lot of capabilities of both chip and CCS, and REALLY well organized with the availability of manual, powerpoints, videos, downloads, and ... everything, all in one place. However...)

In chapter 4, you unplug the LaunchPad to disable GPIO so that you can demonstrate a hardware fault, stating that it is still enabled from the previous version of code. Doesn't RESET disable enabled peripherals? And doesn't reprogramming the part generate a reset? (underneath StellarisWare, we're talking about the RCGCGPIO "register", right? The datasheet SAYS this gets reset to zero on reset...)


--Westfw 04:09, 7 October 2012 (CDT)

Notsane said ...

@Toddintr: In WinXP and Win7 they appear as + signs. If you are using Win8 they may appear differently, but at this time Win8 has not been officially released and I have not written the labs with it in mind.

@Westfw: Should that register get reset by a hardware reset? Absolutely. Does it get reset when CCS provides a reset through the emulation port. No. Is a emulation reset different than a real hardware reset? Apparently. So I definitely could have written the lab so that students would not be aware of this potential issue, but I prefer to make students aware of them.

--Notsane 10:15, 8 October 2012 (CDT)

Notsane said ...

@Toddintr: Also, the lab files are not part of the StellarisWare installation, they are in the lab installation file: http://software-dl.ti.com/trainingTTO/trainingTTO_public_sw/GSW-Stellaris-LaunchPad/StellairisLaunchpadWorkshopFiles-1.0-Setup.exe

--Notsane 10:32, 8 October 2012 (CDT)

Westfw said ...

I did some experiments with chapter4 code and RESET. CCS apparently has two "reset" commands; a "core reset" and a "system reset." A system reset, or the reset button on the launch pad, seems to fully reset everything, and the modified program ends up in FaultISR. Merely loading new code looks like it only causes a core reset, and initialized peripherals stay initialized.


--Westfw 11:08, 8 October 2012 (CDT)

Notsane said ...

@Westfw: Thanks for checking this out. This behaviour is basically what I would expect. I'd like to add that one should always check their code functionality after a power up. All IDE's have to do certain things before main() that may cause unexpected things to happen, or to work when they shouldn't ...

--Notsane 15:11, 8 October 2012 (CDT)

Jokkebk said ...

In Chapter 8 video, the EEPROMRead and EEPROMProgram methods are called with EEPROM memory address 0x400AF000. However, Driverlib user guide suggests the addresses should be relative, such as 0x400 (or 0x0 for first EEPROM byte). The source code in eeprom.c also supports this, as well as the datasheet - the EEPROM as I understand it is not even addressable at 0x400AF000, only the peripheral registers are located there.

In main3.txt which contains the lab example code for EEPROM, two out of three references to 0x400AF000 have been fixed, but the first one remains. Very confusing. You should rectify the video and documentation if possible.

--Jokkebk 06:16, 4 November 2012 (CST)

Notsane said ...

@ Jokkebk: You are absolutely right. I'm in the process of fixing the manual and lab installation files. The video, unfortunately, will have to stay as-is. Thanks!

--Notsane 19:57, 11 December 2012 (CST)

Zigarrre said ...

The link to the lab installation file (http://software-dl.ti.com/trainingTTO/trainingTTO_public_sw/GSW-Stellaris-LaunchPad/StellairisLaunchpadWorkshopFiles-1.0-Setup.exe) is broken (404 error). Can somebody fix this please?

--Zigarrre 11:29, 15 January 2013 (CST)

Notsane said ...

I fixed the link. The one you have doesn't work since it links to the 1.0 version. The link now reads 1.1. Use either of the links in the wiki text and they will work.

Thanks!

--Notsane 12:09, 16 January 2013 (CST)

Crazymexican911 said ...

I was wondering if it would be possible to get a tutorial on ADC from an external input into the LM4F120XL?

--Crazymexican911 04:09, 31 January 2013 (CST)

Notsane said ...

@Crazymexican911: Using an external input to the ADC is as simple as changing the channel. The ADC lab in my earlier workshop does exactly this. The lab is based on the EK-LM4F232 board and measures all three channels of the on-board accelerometer. That material is here: http://processors.wiki.ti.com/index.php/Getting_Started_with_StellarisWare%C2%AE_and_the_ARM%C2%AE_Cortex%E2%84%A2-M4F_Workshop?DCMP=stellaris&HQS=m4fworkshop#Introduction

--Notsane 07:54, 1 February 2013 (CST)

Jneumann said ...

I read through the PDF workbook today (rev 1.05, Jan 2013) and it has been extremely helpful! Thank you for sharing it. However, I ran into a couple minor issues:

1) Lab 9 seems to be missing a part. On page 9-7 the Objective reads "In this lab you will enable the FPU and run both fixed and floating-point code to see the performance difference." However, I don't see anywhere that fixed-point is mentioned or profiled to find the performance difference. Only floating-point is used to calculate a sine wave.

How would a person do the equivalent in fixed-point? Wouldn't the precision be terrible? Please update the workbook, let me know where I can find the fixed-point half of this lab, or let me know how I could do the equivalent with fixed-point. Thank you!

2) In the wiki text it says the KenTec TFT LCD can be purchased from the manufacturer or Newark. But I can’t find anywhere on the manufacturer website to order one, and Newark is out of stock with no ETA. I’ve written the manufacturer via their webpage but would you please share how you ordered from them or how you heard that was possible? Thank you again!

--Jneumann 14:19, 7 February 2013 (CST)

Jneumann said ...

Hi again. I'm also wondering if much ever happens in the Indianapolis, IN area (I'm about an hour south of there). I looked at the locations for the in-person training but unfortunately they are too far away to be practical. The online availability is great but I'm sure there is simply no comparison to being in the same room as several other people to bounce ideas off of, hear their questions, hear random explanations of why "no one does that" etc. Thank you.

--Jneumann 14:40, 7 February 2013 (CST)

Notsane said ...

@Jneumann: I'm glad that you've found the material useful. I'll be adding some new, cool things in the not-too-distant future!

1) My intent was to write an either/or FPU lab to showcase the advantage of using floating point. It turns out though that the compiler is so smart that getting it to not use the FPU isn't a trivial exercise ... the code looks completely different. So I've updated the lab description to eliminate the reference to profiling fixed point code.

2) Newark is supposed to be stocking the displays more regularly starting in May 2013. Don't depend on the web site ... call them on the phone. As far as the manufacturer goes, contact them by email. I've found them to be very responsive. sales@kentecdisplay.com

3) Clicking through the live training links you'll find http://focus.ti.com/docs/training/catalog/events/event.jhtml;jsessionid=HXB4XOAAVXR1RQC1JAKBVQQ?sku=1DW090003&tfsection=Contact+Information Our logistics persons contact information is there. Let Kim know that you'd like to see a live workshop in the Indianapolis area. If it's possible to get enough people, she'll make it happen!

Good luck!

--Notsane 13:35, 12 February 2013 (CST)

NJGUY said ...

Hi I've been trying to follow the tutorials but keep getting the following error:

CORTEX_M4_0: GEL: Encountered a problem loading file: C:\StellarisWare\boards\MyLaunchPadBoard\Lab2\ccs\Debug\Lab2.out Could not open file

Can anyone shed any light on this?

I have followed all the steps in the pdf workbook. I'm using a windows 7 machine. Also where can I find Project 0? It doesn't seem to have been included in my StellarisWare download. I used the link provided in the workbook pdf to get StellarisWare and it only seems to have included the labs


--NJGUY 11:35, 14 February 2013 (CST)

Notsane said ...

@NJGUY: Most likely what's happening here is that you have some sort of compilation error (you placed the project in the wrong location, you mis-entered the paths in the build options, you have syntax errors ...) and then you clicked "Proceed" when the compiler warned you of the issues. The *.out file is the final result of the entire compilation process and is the file that the CCS loader uses to write your code to the M4's flash memory. It can't be found because it was never created. The best thing to do is to check the "Problems" pane and debug from there. Or, you can start over and make sure that you follow the instructions to the letter.

If the only thing you can find in C:\StellarisWare is my labs then you haven't installed StellarisWare. The full StellarisWare installation is at http://www.ti.com/tool/sw-lm3s Once that is installed, you can find Project0 in: C:\StellarisWare\boards\ek-lm4f120xl\project0.

Good Luck!!

--Notsane 08:36, 21 February 2013 (CST)

Bgolab said ...

What MCU type did you get on your Launchpad board? In my case it is LX4F120 rev A3 instead of LM4F120...

--Bgolab 04:16, 24 February 2013 (CST)

Notsane said ...

@bgolab: The "X" denotes a pre-release part. All the boards are populated with this part until the TI release-to-production date.

--Notsane 21:11, 25 February 2013 (CST)

NJGUY said ...

Thanks Notsane. I actually did what you suggested and uninstalled everything and reinstalled. Up and running now.


--NJGUY 09:17, 27 February 2013 (CST)

Crazymexican911 said ...

@Notsane thank you for that link! I was wondering if there was a good tutorial for doing applying FFT on this board??

--Crazymexican911 09:37, 4 March 2013 (CST)

Notsane said ...

@Crazymexican911: Running FFT code on this device is no different than other ARM M4 devices. There are several resources out on the web including the CMSIS DSP library. There will be both fixed and floating point versions, so be aware when setting up the LM4F device. Someone in the group has done an FFT on the LaunchPad. Here's the link: [1]


--Notsane 09:44, 6 March 2013 (CST)

Arsam said ...

The StellarisWare download doesn't seem to support the LM4 (although it says all boards); can I use TivaWare C to complete the labs?

--Arsam 03:25, 18 April 2013 (CDT)

Arsam said ...

I played with the TivaWare examples for the Stellaris launchpad (ek-tm4c123gxl instead of lm4f120...), and I found that it was easier to navigate and every example opened very smoothly (which wasn't always the case in StellarisWare). However , the lab exercises won't run without certain modifications that are very nicely explained in this document: http://www.ti.com/lit/an/spma050/spma050.pdf If anyone has any advice for a beginner, please let me know because i can definitely use some; I've just received my Kentec Display and I have eagerly been trying to learn the hardware and software to get my project going. Thanks

--Arsam 02:05, 21 April 2013 (CDT)

Notsane said ...

Everyone should know rhat the Stellaris brand name is being replaced by the more universal Tiva brand name. This includes major changes to the labs in this workshop. I will place a notification here when the new page is up and ready. ..

--Notsane 12:32, 24 April 2013 (CDT)

Notsane said ...

The new Tiva TM4C123G LaunchPad workshop is now live! Visit http://www.ti.com/TM4C123G-Launchpad-Workshop . There will be significant new material added to the new workshop, so keep your eye on the Wiki.

--Notsane 15:54, 14 May 2013 (CDT)

There are no threads on this page yet.