NOTICE: The Processors Wiki will End-of-Life in December of 2020. It is recommended to download any files or other content you may need that are hosted on processors.wiki.ti.com. The site is now set to read only.

SubVersion plugin installation

From Texas Instruments Wiki
Jump to: navigation, search

Code Composer Studio v5[edit]

Installing a subversion plug-in into CCSv5 is very simple. You can make use of the Eclipse marketplace to find and install the plug-in.

  • From the help menu select "Eclipse Marketplace"

EclipseMarketplaceMenu.png

  • Select the Eclipse marketplace if you are prompted to choose a solution catalog

EclipseMarketplaceCatalog.png

  • In the search box type in "subversion". This will search the marketplace for anything that mentions subversion. Select the plug-in that you want to install. Subclipse is a popular one.

SubversionMarketplace.png

  • Follow the installation wizard. It will automatically pull in any other dependent components that you need to install.


Code Composer Studio v4[edit]

Overview:[edit]

SubEclipse is a plug-in for the Eclipse environment that will enable support for SubVersion within Eclipse based IDE's like CCS.  For more information on the plug-in please visit http://subclipse.tigris.org/ There is also another SubVersion plug-in called SubVersive. We have not tried this one with CCS but it is available here.

Dependencies:[edit]

  1. CCSv4.x.  CCSv4.0 and later are based on the Eclipse open source software framework.
  2. GEF (Graphical Editing Framework) 3.2.2.  The Revision Graph tool for SubVersion requires components of this framework.

Installation Procedure: [edit]

1. Install GEF

First we need to Install GEF. In CCS go to Help -> Software Updates -> Find and Install.

CCSv4 UpdateMenu.jpg


Select to search for new features to install.

UpdateManager.jpg

Click Next.

Click on the button to add a "New Remote Site".

Enter in GEF as the name and http://download.eclipse.org/tools/gef/updates/releases/ as the update site.
CCSv4 NewUpdateSite.jpg

Click finish to check for updates
IMPORTANT!!!!: By default this will just show the latest version available. However you need to install the verison that matches the Eclipse that CCS uses. Uncheck the box at the bottom that says "Show the latest version of a feature only".  Expand "GEF" and then expand "GEF SDK 3.2.2" and select the first item "Graphical Editing Framework 3.2.2...".  If you install a newer version of GEF like 3.6 you will corrupt your installation of CCS.

CCSv4 GEFSelection.jpg

Click next and follow the wizard to complete the installation.  You will have to agree to the license agreement, it may also mention that some components are unsigned.  Just click the "Install All" button.

2. Restart CCS

It will ask you to restart the workbench say yes to close CCS and restart it.

3. Install SubEclipse

You can use the SubEclipse update site to install the SubVersion plugin. In CCS go to Help -> Software Updates -> Find and Install.

CCSv4 UpdateMenu.jpg

Select to search for new features to install.

UpdateManager.jpg

Click Next.

Click on the button to add a "New Remote Site". Enter in SubEclipse as the name and http://subclipse.tigris.org/update_1.4.x as the update site.
CCSv4 SubEclipseUpdateSite.jpg

Click finish to check for updates. This will find the subversion plug-in.

Check the box that says "SubEclipse".
You will need to uncheck the box for "Integrations (optional)" unless you also have MyLyn installed.
CCSv4 SubEclipseUpdates.jpg

Click Finish to install the required plugins.

4. Restart CCS

It may ask you to restart the workbench say yes to close CCS and restart it.


Done!

 

 

 

E2e.jpg {{
  1. switchcategory:MultiCore=
  • For technical support on MultiCore devices, please post your questions in the C6000 MultiCore Forum
  • For questions related to the BIOS MultiCore SDK (MCSDK), please use the BIOS Forum

Please post only comments related to the article SubVersion plugin installation here.

Keystone=
  • For technical support on MultiCore devices, please post your questions in the C6000 MultiCore Forum
  • For questions related to the BIOS MultiCore SDK (MCSDK), please use the BIOS Forum

Please post only comments related to the article SubVersion plugin installation here.

C2000=For technical support on the C2000 please post your questions on The C2000 Forum. Please post only comments about the article SubVersion plugin installation here. DaVinci=For technical support on DaVincoplease post your questions on The DaVinci Forum. Please post only comments about the article SubVersion plugin installation here. MSP430=For technical support on MSP430 please post your questions on The MSP430 Forum. Please post only comments about the article SubVersion plugin installation here. OMAP35x=For technical support on OMAP please post your questions on The OMAP Forum. Please post only comments about the article SubVersion plugin installation here. OMAPL1=For technical support on OMAP please post your questions on The OMAP Forum. Please post only comments about the article SubVersion plugin installation here. MAVRK=For technical support on MAVRK please post your questions on The MAVRK Toolbox Forum. Please post only comments about the article SubVersion plugin installation here. For technical support please post your questions at http://e2e.ti.com. Please post only comments about the article SubVersion plugin installation here.

}}

Hyperlink blue.png Links

Amplifiers & Linear
Audio
Broadband RF/IF & Digital Radio
Clocks & Timers
Data Converters

DLP & MEMS
High-Reliability
Interface
Logic
Power Management

Processors

Switches & Multiplexers
Temperature Sensors & Control ICs
Wireless Connectivity